码迷,mamicode.com
首页 > 其他好文 > 详细

bzoj2705 [SDOI2012]Longge的问题

时间:2017-08-17 00:40:26      阅读:247      评论:0      收藏:0      [点我收藏+]

标签:problems   desc   数学   暴力   arc   ace   div   有一个   can   

2705: [SDOI2012]Longge的问题

Time Limit: 3 Sec  Memory Limit: 128 MB
Submit: 3160  Solved: 1973
[Submit][Status][Discuss]

Description

Longge的数学成绩非常好,并且他非常乐于挑战高难度的数学问题。现在问题来了:给定一个整数N,你需要求出∑gcd(i, N)(1<=i <=N)。

Input

一个整数,为N。

Output

一个整数,为所求的答案。

Sample Input

6

Sample Output

15

HINT

 

【数据范围】

对于60%的数据,0<N<=2^16。

对于100%的数据,0<N<=2^32。

 

 

Source

round1 day1

分析:如果直接暴力求gcd,n^2的枚举时间加上每次求gcd的时间,直接爆掉,那么能不能用更好的方法做呢?

       我们可以换个思路,要求Σgcd(i,n),我们假设gcd(i,n) = g,也就是我们要求以g为最大公约数的(i,n)有多少对,然后g对答案的贡献就是g*个数,显然,这个g是n的约数,对于约数的枚举我们有一个技巧,就是只枚举到它的sqrt即可,和它成对的一个约数就是n/i,前提是i != sqrt(n).如果g = 1,我们可以直接用欧拉函数来统计,如果g != 1呢?那么我们可以把i,n写作i = i‘*g,n = n‘*g,i和n同时除以g,那么n和i就互质了,这样直接用欧拉函数就可以解决问题了.

#include <cstdio>
#include <queue>
#include <cstring>
#include <iostream>
#include <algorithm>
#include <cmath>

using namespace std;

long long n,ans;

long long phi(long long x)
{
    long long res = x;
    for (long long i = 2; i <= sqrt(x); i++)
    {
        if (x % i == 0)
        {
            while (x % i == 0)
                x /= i;
            res = res / i * (i - 1);
        }
    }
    if (x > 1)
        res = res / x * (x - 1);
    return res;
}

int main()
{
    scanf("%lld", &n);
    for (long long i = 1; i <= sqrt(n); i++)
    {
        if (n % i == 0)
        {
            ans += i * phi(n / i);
            if (i * i < n)
                ans += n / i * phi(i);
        }
    }
    printf("%lld\n", ans);

    return 0;
}

 

bzoj2705 [SDOI2012]Longge的问题

标签:problems   desc   数学   暴力   arc   ace   div   有一个   can   

原文地址:http://www.cnblogs.com/zbtrs/p/7376580.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!