码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 2795 Billboard(线段树)

时间:2017-08-17 13:04:11      阅读:217      评论:0      收藏:0      [点我收藏+]

标签:i++   oom   include   mono   nts   ever   case   php   lan   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=2795

Billboard

Time Limit: 20000/8000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 16673    Accepted Submission(s): 7056


Problem Description
At the entrance to the university, there is a huge rectangular billboard of size h*w (h is its height and w is its width). The board is the place where all possible announcements are posted: nearest programming competitions, changes in the dining room menu, and other important information.

On September 1, the billboard was empty. One by one, the announcements started being put on the billboard.

Each announcement is a stripe of paper of unit height. More specifically, the i-th announcement is a rectangle of size 1 * wi.

When someone puts a new announcement on the billboard, she would always choose the topmost possible position for the announcement. Among all possible topmost positions she would always choose the leftmost one.

If there is no valid location for a new announcement, it is not put on the billboard (that‘s why some programming contests have no participants from this university).

Given the sizes of the billboard and the announcements, your task is to find the numbers of rows in which the announcements are placed.
 

Input
There are multiple cases (no more than 40 cases).

The first line of the input file contains three integer numbers, h, w, and n (1 <= h,w <= 10^9; 1 <= n <= 200,000) - the dimensions of the billboard and the number of announcements.

Each of the next n lines contains an integer number wi (1 <= wi <= 10^9) - the width of i-th announcement.
 

Output
For each announcement (in the order they are given in the input file) output one number - the number of the row in which this announcement is placed. Rows are numbered from 1 to h, starting with the top row. If an announcement can‘t be put on the billboard, output "-1" for this announcement.
 

Sample Input
3 5 5 2 4 3 3 3
 

Sample Output
1 2 1 3 -1
 

Author
hhanger@zju
 

Source
 

Recommend
lcy   |   We have carefully selected several similar problems for you:  1698 1542 1828 1540 1255 
 
题目大意:一个h*w的公告牌,要在其上贴公告。

  • 输入的是1*wi的w值,这些是公告的尺寸
  • 接下来要满足的条件有:1、尽量往上。同一高度尽量靠左。

    2、求第n个广告所在的行数。3、没有合适的位置贴了则输出-1。

解题思路:利用线段树能够得出区间的最大值,在结构体中定义一个Max变量,用来表示这段区间内有最多空位的那一行的空位长度。与输入进来的长度进行比較,先左边比較。再右边。

(也就是左子树的最大值大于他,就查询左子树,否则查询右子树)。



详见代码。
#include <iostream>
#include <cstdio>
#include <cstring>

using namespace std;

struct node
{
    int l,r;
    int Max;//这段区间内有最多空位的那一行的空位长度
} s[200000*4];

void InitTree(int l,int r,int k,int w)
{
    s[k].l=l;
    s[k].r=r;
    s[k].Max=w;
    if (l==r)
        return ;
    int mid=(l+r)/2;
    InitTree(l,mid,2*k,w);
    InitTree(mid+1,r,2*k+1,w);
}

void UpdataTree(int ww,int k)
{
    if (s[k].l==s[k].r)
    {
        printf ("%d\n",s[k].l);
        s[k].Max-=ww;
        return ;
    }
    if (ww<=s[k*2].Max)
        UpdataTree(ww,k*2);
    else
        UpdataTree(ww,k*2+1);
    s[k].Max=s[k*2].Max>s[k*2+1].Max?s[k*2].Max:s[k*2+1].Max;
}

int main()
{
    int h,w,n;
    int ww;
    while (~scanf("%d%d%d",&h,&w,&n))
    {
        if (h>n)//h<=n,大了就没有意义了
            h=n;
        InitTree(1,h,1,w);
        for (int i=1; i<=n; i++)
        {
            scanf("%d",&ww);
            if (s[1].Max>=ww)
                UpdataTree(ww,1);
            else
                printf ("-1\n");
        }
    }
    return 0;
}



hdu 2795 Billboard(线段树)

标签:i++   oom   include   mono   nts   ever   case   php   lan   

原文地址:http://www.cnblogs.com/ljbguanli/p/7380576.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!