码迷,mamicode.com
首页 > 其他好文 > 详细

【练习赛2补题】zoj 2734 Exchange Cards 【DFS】

时间:2017-08-18 18:45:11      阅读:179      评论:0      收藏:0      [点我收藏+]

标签:--   价值   dep   nts   use   string   gre   return   logs   

As a basketball fan, Mike is also fond of collecting basketball player cards. But as a student, he can not always get the money to buy new cards, so sometimes he will exchange with his friends for cards he likes. Of course, different cards have different value, and Mike must use cards he owns to get the new one. For example, to get a card of value 10$, he can use two 5$ cards or three 3$ cards plus one 1$ card, depending on the kinds of cards he have and the number of each kind of card. And Sometimes he will involve unfortunately in a bad condition that he has not got the exact value of the card he is looking for (fans always exchange cards for equivalent value).

Here comes the problem, given the card value he plans to get and the cards he has, Mike wants to fix how many ways he can get it. So it‘s you task to write a program to figure it out.

Input

The problem consists of multiple test cases, terminated by EOF. There‘s a blank line between two inputs.

The first line of each test case gives n, the value of the card Mike plans to get and m, the number of different kinds of cards Mike has. n will be an integer number between 1 and 1000. m will be an integer number between 1 and 10.

The next m lines give the information of different kinds of cards Mike have. Each line contains two integers, val and num, representing the value of this kind of card, and the number of this kind of card Mike have.

Note: different kinds of cards will have different value, each val and num will be an integer greater than zero.

Output

For each test case, output in one line the number of different ways Mike could exchange for the card he wants. You can be sure that the output will fall into an integer value.

Output a blank line between two test cases.

Sample Input

5 2
2 1
3 1

10 5
10 2
7 2
5 3
2 2
1 5

Sample Output

1

7

题意:输入价值总v及行数m,每行输入两个整数,价值si和该价值的卡片数目ni,问,各价值组合得到总价值的组合方式有多少种?
思路:只要题意get到就是一个dfs,注意,两个样例之间有空行
#include<stdio.h>
#include<string.h>

#define N 1010
int num[N];
int v,m,sum,ans;

void dfs(int k)
{
    int i;
    if(sum == v)
    {
        ans++;
        return;
    }
    for(i = k; i <= v; i ++)
    {
        if(sum + i <= v&&num[i] > 0)
        {
            num[i]--;
            sum += i;
            dfs(i);
            num[i]++;
            sum -= i;
        }
    }    
    return;
}
int main()
{
    int t1,t2,i;
    int t = 0;
    while(scanf("%d%d",&v,&m)!=EOF)
    {
        ans = sum = 0;
        if(t)
            printf("\n");
        memset(num,0,sizeof(num));
        for( i = 1; i <= m; i ++)
        {
            scanf("%d%d",&t1,&t2);
            num[t1] = t2;
        }
        dfs(1);
        printf("%d\n",ans);
        t++;
    }
    return 0;
}

 



 

【练习赛2补题】zoj 2734 Exchange Cards 【DFS】

标签:--   价值   dep   nts   use   string   gre   return   logs   

原文地址:http://www.cnblogs.com/chengdongni/p/7390861.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!