码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1269 迷宫城堡

时间:2017-08-20 18:33:22      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:key   mit   map   arc   tput   水题   while   rdo   方向   

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 17377    Accepted Submission(s): 7617


Problem Description
为了训练小希的方向感,Gardon建立了一座大城堡,里面有N个房间(N<=10000)和M条通道(M<=100000),每个通道都是单向的,就是说若称某通道连通了A房间和B房间,只说明可以通过这个通道由A房间到达B房间,但并不说明通过它可以由B房间到达A房间。Gardon需要请你写个程序确认一下是否任意两个房间都是相互连通的,即:对于任意的i和j,至少存在一条路径可以从房间i到房间j,也存在一条路径可以从房间j到房间i。
 

 

Input
输入包含多组数据,输入的第一行有两个数:N和M,接下来的M行每行有两个数a和b,表示了一条通道可以从A房间来到B房间。文件最后以两个0结束。
 

 

Output
对于输入的每组数据,如果任意两个房间都是相互连接的,输出"Yes",否则输出"No"。
 

 

Sample Input
3 3
1 2
2 3
3 1
3 3
1 2
2 3
3 2
0 0
 

 

Sample Output
Yes
No
 

 

Author
Gardon
 

 

Source
 
mmp这种水题错这么多次真该剁手啊。。
①没清空sumcol②习惯双向边
#include <cstring>
#include <cstdio>
#include <vector>
#define N 100500

using std::vector;
int min(int a,int b) {return a>b?b:a;}
vector<int>edge[N];
bool instack[N];
int Map[1005][1005],n,m,dfn[N],stack[N],low[N],tim,top,sumcol;
inline void init()
{
    sumcol=top=tim=0;
    memset(dfn,0,sizeof(dfn));
    memset(low,0,sizeof(low));
}
void tarjan(int x)
{
    stack[++top]=x;
    instack[x]=true;
    dfn[x]=low[x]=++tim;
    for(int i=0;i<edge[x].size();++i)
    {
        int v=edge[x][i];
        if(instack[v]) low[x]=min(low[x],dfn[v]);
        else if(!dfn[v])
        {
            tarjan(v);
            low[x]=min(low[x],low[v]);
        }
    }
    if(low[x]==dfn[x])
    {
        sumcol++;
        int k;
        do
        {
            k=stack[top--];
            instack[k]=false;
        }while(k!=x);
    }
}
int main()
{
    for(;scanf("%d%d",&n,&m)&&n;)
    {
        for(int x,y;m--;)
        {
            scanf("%d%d",&x,&y);
            edge[x].push_back(y);
        }
        for(int i=1;i<=n;++i)
            if(!dfn[i]) tarjan(i);
        if(sumcol==1) printf("Yes\n");
        else printf("No\n");
        for(int i=1;i<=n;++i) edge[i].clear();
        init();
    }
    return 0;
}

 

hdu 1269 迷宫城堡

标签:key   mit   map   arc   tput   水题   while   rdo   方向   

原文地址:http://www.cnblogs.com/ruojisun/p/7400479.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!