码迷,mamicode.com
首页 > 其他好文 > 详细

luogu P2863 [USACO06JAN]牛的舞会The Cow Prom

时间:2017-08-20 22:36:03      阅读:219      评论:0      收藏:0      [点我收藏+]

标签:逆时针   head   success   line   for   count   圆形   direct   ons   

https://www.luogu.org/problem/show?pid=2863#sub

题目描述

The N (2 <= N <= 10,000) cows are so excited: it‘s prom night! They are dressed in their finest gowns, complete with corsages and new shoes. They know that tonight they will each try to perform the Round Dance.

Only cows can perform the Round Dance which requires a set of ropes and a circular stock tank. To begin, the cows line up around a circular stock tank and number themselves in clockwise order consecutively from 1..N. Each cow faces the tank so she can see the other dancers.

They then acquire a total of M (2 <= M <= 50,000) ropes all of which are distributed to the cows who hold them in their hooves. Each cow hopes to be given one or more ropes to hold in both her left and right hooves; some cows might be disappointed.

约翰的N (2 <= N <= 10,000)只奶牛非常兴奋,因为这是舞会之夜!她们穿上礼服和新鞋子,别 上鲜花,她们要表演圆舞.

只有奶牛才能表演这种圆舞.圆舞需要一些绳索和一个圆形的水池.奶牛们围在池边站好, 顺时针顺序由1到N编号.每只奶牛都面对水池,这样她就能看到其他的每一只奶牛.

为了跳这种圆舞,她们找了 M(2<M< 50000)条绳索.若干只奶牛的蹄上握着绳索的一端, 绳索沿顺时针方绕过水池,另一端则捆在另一些奶牛身上.这样,一些奶牛就可以牵引另一些奶 牛.有的奶牛可能握有很多绳索,也有的奶牛可能一条绳索都没有.

对于一只奶牛,比如说贝茜,她的圆舞跳得是否成功,可以这样检验:沿着她牵引的绳索, 找到她牵引的奶牛,再沿着这只奶牛牵引的绳索,又找到一只被牵引的奶牛,如此下去,若最终 能回到贝茜,则她的圆舞跳得成功,因为这一个环上的奶牛可以逆时针牵引而跳起旋转的圆舞. 如果这样的检验无法完成,那她的圆舞是不成功的.

如果两只成功跳圆舞的奶牛有绳索相连,那她们可以同属一个组合.

给出每一条绳索的描述,请找出,成功跳了圆舞的奶牛有多少个组合?

For the Round Dance to succeed for any given cow (say, Bessie), the ropes that she holds must be configured just right. To know if Bessie‘s dance is successful, one must examine the set of cows holding the other ends of her ropes (if she has any), along with the cows holding the other ends of any ropes they hold, etc. When Bessie dances clockwise around the tank, she must instantly pull all the other cows in her group around clockwise, too. Likewise,

if she dances the other way, she must instantly pull the entire group counterclockwise (anti-clockwise in British English).

Of course, if the ropes are not properly distributed then a set of cows might not form a proper dance group and thus can not succeed at the Round Dance. One way this happens is when only one rope connects two cows. One cow could pull the other in one direction, but could not pull the other direction (since pushing ropes is well-known to be fruitless). Note that the cows must Dance in lock-step: a dangling cow (perhaps with just one rope) that is eventually pulled along disqualifies a group from properly performing the Round Dance since she is not immediately pulled into lockstep with the rest.

Given the ropes and their distribution to cows, how many groups of cows can properly perform the Round Dance? Note that a set of ropes and cows might wrap many …

输入输出格式

输入格式:

 

Line 1: Two space-separated integers: N and M

Lines 2..M+1: Each line contains two space-separated integers A and B that describe a rope from cow A to cow B in the clockwise direction.

 

输出格式:

 

Line 1: A single line with a single integer that is the number of groups successfully dancing the Round Dance.

 

输入输出样例

输入样例#1:
5 4
2 4
3 5
1 2
4 1
输出样例#1:
1

说明

 

裸地板子题

 

技术分享
#include<bits/stdc++.h>
using namespace std;
#define maxn 1000000
int n,m,head[maxn],num,x,y,z,a,b,c;

struct Type{
    int u,v,d,next;
}edge[maxn];

int tim,tot,ans=0,dfn[maxn],low[maxn],col[maxn],sta[maxn],top,sumcol,point[maxn];
bool vis[maxn];

void ins(int u,int v)
{
    edge[++num].v=v;
    edge[num].next=head[u];
    head[u]=num;
}

void dfs(int now)
{
    low[now]=dfn[now]=++tim;
    sta[++top]=now;
    vis[now]=true;
    for(int i=head[now];i;i=edge[i].next)
    {
        int v=edge[i].v;
        if(vis[v]) low[now]=min(low[now],dfn[v]);
        else if(!dfn[v]) dfs(v),low[now]=min(low[now],low[v]);
    }
    if(low[now]==dfn[now])
    {
        col[now]=++sumcol;
        point[sumcol]++;
        for(;sta[top]!=now;top--)
        {
            col[sta[top]]=sumcol;
            point[sumcol]++;
            vis[sta[top]]=false;
        }
        top--;
        vis[sta[top]]=false;
    }
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++) scanf("%d%d",&x,&y),ins(x,y);
    for(int i=1;i<=n;i++) if(!dfn[i]) dfs(i);
    for(int i=1;i<=sumcol;i++) if(point[i]>1) ans++;
    printf("%d",ans);
    return 0;
}
View Code

 

luogu P2863 [USACO06JAN]牛的舞会The Cow Prom

标签:逆时针   head   success   line   for   count   圆形   direct   ons   

原文地址:http://www.cnblogs.com/chen74123/p/7401348.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!