码迷,mamicode.com
首页 > 其他好文 > 详细

Balance POJ - 1837 地推

时间:2017-08-21 13:30:01      阅读:173      评论:0      收藏:0      [点我收藏+]

标签:amp   main   output   arm   man   size   int   form   bitset   

Gigel has a strange "balance" and he wants to poise it. Actually, the device is different from any other ordinary balance. 
It orders two arms of negligible weight and each arm‘s length is 15. Some hooks are attached to these arms and Gigel wants to hang up some weights from his collection of G weights (1 <= G <= 20) knowing that these weights have distinct values in the range 1..25. Gigel may droop any weight of any hook but he is forced to use all the weights. 
Finally, Gigel managed to balance the device using the experience he gained at the National Olympiad in Informatics. Now he would like to know in how many ways the device can be balanced. 

Knowing the repartition of the hooks and the set of the weights write a program that calculates the number of possibilities to balance the device. 
It is guaranteed that will exist at least one solution for each test case at the evaluation. 

Input

The input has the following structure: 
? the first line contains the number C (2 <= C <= 20) and the number G (2 <= G <= 20); 
? the next line contains C integer numbers (these numbers are also distinct and sorted in ascending order) in the range -15..15 representing the repartition of the hooks; each number represents the position relative to the center of the balance on the X axis (when no weights are attached the device is balanced and lined up to the X axis; the absolute value of the distances represents the distance between the hook and the balance center and the sign of the numbers determines the arm of the balance to which the hook is attached: ‘-‘ for the left arm and ‘+‘ for the right arm); 
? on the next line there are G natural, distinct and sorted in ascending order numbers in the range 1..25 representing the weights‘ values. 

Output

The output contains the number M representing the number of possibilities to poise the balance.

Sample Input

2 4	
-2 3 
3 4 5 8

Sample Output

2


递推,注意到砝码一边的最大重量不超过7500,讲7500设为新的0点,枚举所有物品选择和节点选择,注意剪枝。。
#include<iostream>
#include<cstdio>
#include<cmath>
#include<cstring>
#include<sstream>
#include<algorithm>
#include<queue>
#include<vector>
#include<cmath>
#include<map>
#include<stack>
#include<set>
#include<memory>
#include<bitset>
#include<string>
#include<functional>
using namespace std;
typedef long long LL;
typedef unsigned long long ULL;
const int MAXN = 8000 * 2;

#define INF 0x3f3f3f3f

//0 1 背包
/*
dp[i][MAXN]
*/
int dp[25][MAXN];
int x[25], w[25];
int solve(int c, int g)
{
    for (int i = 1; i <= g; i++)
    {
        for (int v = 0; v < MAXN; v++)
        {
            if (dp[i - 1][v])
            {
                for (int j = 1; j <= c; j++)
                {
                    dp[i][v + w[i] * x[j]] += dp[i - 1][v];
                }
            }
        }
    }
    return dp[g][7500];
}
int main()
{
    int c, g;
    scanf("%d%d", &c, &g);
    memset(dp, 0, sizeof(dp));
    for (int i = 1; i <= c; i++)
        scanf("%d", &x[i]);
    for (int j = 1; j <= g; j++)
        scanf("%d", &w[j]);
    /*for (int i = 0; i < c; i++)
    {
        for (int j = 0; j < g; j++)
        {
            dp[0][x[i] * w[j] + 7500]++;
        }
    }*/
    dp[0][7500] = 1;
    printf("%d\n", solve(c, g));
    return 0;
}

 

Balance POJ - 1837 地推

标签:amp   main   output   arm   man   size   int   form   bitset   

原文地址:http://www.cnblogs.com/joeylee97/p/7403763.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!