码迷,mamicode.com
首页 > 其他好文 > 详细

D - Interesting Calculator 【BFS+优先队列】

时间:2017-08-21 20:31:46      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:cst   number   show   turn   and   printf   blog   val   value   

There is an interesting calculator. It has 3 rows of buttons.

 

Row 1: button 0, 1, 2, 3, ..., 9. Pressing each button appends that digit to the end of the display.

Row 2: button +0, +1, +2, +3, ..., +9. Pressing each button adds that digit to the display.

Row 3: button *0, *1, *2, *3, ..., *9. Pressing each button multiplies that digit to the display.

 

Note that it never displays leading zeros, so if the current display is 0, pressing 5 makes it 5 instead of 05. If the current display is 12, you can press button 3, +5, *2 to get 256. Similarly, to change the display from 0 to 1, you can press 1 or +1 (but not both!).

 

Each button has a positive cost, your task is to change the display from x to y with minimum cost. If there are multiple ways to do so, the number of presses should be minimized.

 

Input

There will be at most 30 test cases. The first line of each test case contains two integers x and y(0<=x<=y<=105). Each of the 3 lines contains 10 positive integers (not greater than 105), i.e. the costs of each button.

 

Output

For each test case, print the minimal cost and the number of presses.

 

Sample Input

12 256
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
1 1 1 1 1 1 1 1 1 1
12 256
100 100 100 1 100 100 100 100 100 100
100 100 100 100 100 1 100 100 100 100
100 100 10 100 100 100 100 100 100 100

Sample Output

Case 1: 2 2
Case 2: 12 3
技术分享
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<iostream>
#include<string>
#include<vector>
#include<stack>
#include<bitset>
#include<cstdlib>
#include<cmath>
#include<set>
#include<list>
#include<deque>
#include<map>
#include<queue>
#define ll long long
#define inf 0x3fffffff
using namespace std;
struct Node
{
    int time;
    int cost;
    int value;
    friend bool operator < (Node a,Node b)
    {
        if(a.cost==b.cost)
            return a.time>b.time;
        return a.cost>b.cost;
    }
}node;
priority_queue<Node> q;
int val[100005];
int mp[5][15];
int cas=1;
int x,y,i,j;

void bfs()
{
    node.time=0;
    node.cost=0;
    node.value=x;
    while(!q.empty()) q.pop();
    q.push(node);
    val[x]=0;
    while(!q.empty())
    {
        Node tp,tmp=q.top();
        q.pop();
        if(tmp.value==y)
       {
            printf("Case %d: %d %d\n",cas++,tmp.cost,tmp.time);
            return ;
        }
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<=9;j++)
            {
                if(i==0)
                    tp.value=tmp.value*10+j;
                else if(i==1)
                    tp.value=tmp.value+j;
                else
                    tp.value=tmp.value*j;

                    tp.cost=tmp.cost+mp[i][j];
                    tp.time=tmp.time+1;

               if(tp.value<=y&&tp.cost<val[tp.value])
                 {
                       q.push(tp);
                     val[tp.value]=tp.cost;
                 }
            }
        }
    }
}
int main()
{
    while(~scanf("%d%d",&x,&y))
    {
        for(int i=0;i<100005;i++)
        val[i]=999999;
        for(int i=0;i<3;i++)
        {
            for(int j=0;j<10;j++)
            {
                scanf("%d",&mp[i][j]);
            }
        }
        bfs();
    }
    return 0;
}
View Code

 



D - Interesting Calculator 【BFS+优先队列】

标签:cst   number   show   turn   and   printf   blog   val   value   

原文地址:http://www.cnblogs.com/Roni-i/p/7406276.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!