码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-2896 病毒侵袭(AC自动机)

时间:2017-08-22 19:09:35      阅读:188      评论:0      收藏:0      [点我收藏+]

标签:aac   insert   世界   name   color   ras   other   ack   问题   

病毒侵袭

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 28843    Accepted Submission(s): 6662


Problem Description
当太阳的光辉逐渐被月亮遮蔽,世界失去了光明,大地迎来最黑暗的时刻。。。。在这样的时刻,人们却异常兴奋——我们能在有生之年看到500年一遇的世界奇观,那是多么幸福的事儿啊~~
但网路上总有那么些网站,开始借着民众的好奇心,打着介绍日食的旗号,大肆传播病毒。小t不幸成为受害者之一。小t如此生气,他决定要把世界上所有带病毒的网站都找出来。当然,谁都知道这是不可能的。小t却执意要完成这不能的任务,他说:“子子孙孙无穷匮也!”(愚公后继有人了)。
万事开头难,小t收集了好多病毒的特征码,又收集了一批诡异网站的源码,他想知道这些网站中哪些是有病毒的,又是带了怎样的病毒呢?顺便还想知道他到底收集了多少带病毒的网站。这时候他却不知道何从下手了。所以想请大家帮帮忙。小t又是个急性子哦,所以解决问题越快越好哦~~
 

 

Input
第一行,一个整数N(1<=N<=500),表示病毒特征码的个数。
接下来N行,每行表示一个病毒特征码,特征码字符串长度在20—200之间。
每个病毒都有一个编号,依此为1—N。
不同编号的病毒特征码不会相同。
在这之后一行,有一个整数M(1<=M<=1000),表示网站数。
接下来M行,每行表示一个网站源码,源码字符串长度在7000—10000之间。
每个网站都有一个编号,依此为1—M。
以上字符串中字符都是ASCII码可见字符(不包括回车)。
 

 

Output
依次按如下格式输出按网站编号从小到大输出,带病毒的网站编号和包含病毒编号,每行一个含毒网站信息。
web 网站编号: 病毒编号 病毒编号 …
冒号后有一个空格,病毒编号按从小到大排列,两个病毒编号之间用一个空格隔开,如果一个网站包含病毒,病毒数不会超过3个。
最后一行输出统计信息,如下格式
total: 带病毒网站数
冒号后有一个空格。
 

 

Sample Input
3
aaa
bbb
ccc
2
aaabbbccc
bbaacc
 

 

Sample Output
web 1: 1 2 3
total: 1

 感觉AC自动机是个很神奇的数据结构,就像把字典树和KMP算法结合到了一起一样

#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<vector>
#include<queue>
using namespace std;
const int N = 210 * 500;
const int maxn = 128;
struct Aho_Corasick{
    int next[N][maxn], fail[N], data[N];
    int root, sz;
    int newnode(){
        for(int i = 0; i < maxn; i++) next[sz][i] = -1;
        data[sz] = -1;
        return sz++;
    }
    void Init() {sz = 0; root = newnode(); }

    void Insert(char *str, int v){
        int len = strlen(str), u = root;
        for(int i = 0; i < len; i++){
            if(next[u][str[i]] == -1)
                next[u][str[i]] = newnode();
            u = next[u][str[i]];
        }
        data[u] = v;
    }
    void Build(){
        queue<int> Q;
        fail[root] = root;
        for(int i = 0; i < maxn; i++){
            if(next[root][i] == -1) next[root][i] = root;
            else{
                fail[next[root][i]] = root;
                Q.push(next[root][i]);
            }
        }
        while(!Q.empty()){
            int u = Q.front(); Q.pop();
            for(int i = 0; i < 128; i++){
                if(next[u][i] == -1) next[u][i] = next[fail[u]][i];
                else{
                    fail[next[u][i]] = next[fail[u]][i];
                    Q.push(next[u][i]);
                }
            }
        }
    }
    vector<int> res;
    bool Query(char *str, int v){
        int len = strlen(str), u = root;
        res.clear();
        for(int i = 0; i < len; i++){
            u = next[u][str[i]];
            int tmp = u;
            while(tmp != root){
                if(data[tmp] != -1){
                    res.push_back(data[tmp]);
                }
                tmp = fail[tmp];
            }
        }
        if(!res.size()) return false;
        sort(res.begin(), res.end());
        printf("web %d:", v);
        for(int i = 0; i < res.size(); i++) printf(" %d", res[i]);
        printf("\n");
        return true;
    }

}AC;
char str[10010];

int main(){
    int n,m;
    scanf("%d",&n);
    AC.Init();
    for(int i=1;i<=n;i++){
        scanf("%s",str);
        AC.Insert(str,i);
    }
    AC.Build();
    int ans=0;
    scanf("%d",&m);
    for(int i=1;i<=m;i++){
        scanf("%s",str);
        if(AC.Query(str,i)) ans++;
    }
    printf("total: %d\n",ans);
    return 0;
}

 

  

HDU-2896 病毒侵袭(AC自动机)

标签:aac   insert   世界   name   color   ras   other   ack   问题   

原文地址:http://www.cnblogs.com/Pretty9/p/7413103.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!