码迷,mamicode.com
首页 > 其他好文 > 详细

POJ - 2393Yogurt factory

时间:2017-08-24 21:30:23      阅读:200      评论:0      收藏:0      [点我收藏+]

标签:min   storage   man   style   def   produced   ini   detail   desc   

The cows have purchased a yogurt factory that makes world-famous Yucky Yogurt. Over the next N (1 <= N <= 10,000) weeks, the price of milk and labor will fluctuate weekly such that it will cost the company C_i (1 <= C_i <= 5,000) cents to produce one unit of yogurt in week i. Yucky‘s factory, being well-designed, can produce arbitrarily many units of yogurt each week.

Yucky Yogurt owns a warehouse that can store unused yogurt at a constant fee of S (1 <= S <= 100) cents per unit of yogurt per week. Fortuitously, yogurt does not spoil. Yucky Yogurt‘s warehouse is enormous, so it can hold arbitrarily many units of yogurt.

Yucky wants to find a way to make weekly deliveries of Y_i (0 <= Y_i <= 10,000) units of yogurt to its clientele (Y_i is the delivery quantity in week i). Help Yucky minimize its costs over the entire N-week period. Yogurt produced in week i, as well as any yogurt already in storage, can be used to meet Yucky‘s demand for that week.
Input
* Line 1: Two space-separated integers, N and S.

* Lines 2..N+1: Line i+1 contains two space-separated integers: C_i and Y_i.
Output
* Line 1: Line 1 contains a single integer: the minimum total cost to satisfy the yogurt schedule. Note that the total might be too large for a 32-bit integer.
Sample Input
4 5
88 200
89 400
97 300
91 500
Sample Output
126900
Hint
OUTPUT DETAILS:
In week 1, produce 200 units of yogurt and deliver all of it. In week 2, produce 700 units: deliver 400 units while storing 300 units. In week 3, deliver the 300 units that were stored. In week 4, produce and deliver 500 units.
 
 
题解:
不难发现每个产品的价格(在不同的周)都是一次函数的变化,所以我们只要对于横坐标x(周),求出那一周生产的产品在这周花费最小,然后用花费乘以对应的数量就可以了。
 
代码:
#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <iostream>
#include <vector>
#define ll long long
#define MAXN 50010
using namespace std;
int cost[MAXN],mai[MAXN];
int n,s;
ll ans=0;
int main()
{
    scanf("%d%d",&n,&s);
    for(int i=1;i<=n;i++){
        scanf("%d%d",&cost[i],&mai[i]);
    }
    for(int wek=1;wek<=n;wek++){
        int minn=1<<30;
        for(int i=1;i<=wek;i++){
            minn=min(minn,cost[i]+s*(wek-i));
        }
        ans+=minn*mai[wek];
    }
    printf("%lld",ans);
    return 0;
}

 

POJ - 2393Yogurt factory

标签:min   storage   man   style   def   produced   ini   detail   desc   

原文地址:http://www.cnblogs.com/renjianshige/p/7425147.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!