码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 3258 River Hopscotch 二分答案

时间:2014-05-10 03:39:32      阅读:404      评论:0      收藏:0      [点我收藏+]

标签:acm   c++   poj   二分   

River Hopscotch
Time Limit: 2000MS   Memory Limit: 65536K
Total Submissions: 6193   Accepted: 2685

Description

Every year the cows hold an event featuring a peculiar version of hopscotch that involves carefully jumping from rock to rock in a river. The excitement takes place on a long, straight river with a rock at the start and another rock at the end, L units away from the start (1 ≤ L ≤ 1,000,000,000). Along the river between the starting and ending rocks, N (0 ≤ N ≤ 50,000) more rocks appear, each at an integral distance Di from the start (0 < Di <L).

To play the game, each cow in turn starts at the starting rock and tries to reach the finish at the ending rock, jumping only from rock to rock. Of course, less agile cows never make it to the final rock, ending up instead in the river.

Farmer John is proud of his cows and watches this event each year. But as time goes by, he tires of watching the timid cows of the other farmers limp across the short distances between rocks placed too closely together. He plans to remove several rocks in order to increase the shortest distance a cow will have to jump to reach the end. He knows he cannot remove the starting and ending rocks, but he calculates that he has enough resources to remove up to rocks (0 ≤ M ≤ N).

FJ wants to know exactly how much he can increase the shortest distance *before* he starts removing the rocks. Help Farmer John determine the greatest possible shortest distance a cow has to jump after removing the optimal set of M rocks.

Input

Line 1: Three space-separated integers: LN, and M 
Lines 2..N+1: Each line contains a single integer indicating how far some rock is away from the starting rock. No two rocks share the same position.

Output

Line 1: A single integer that is the maximum of the shortest distance a cow has to jump after removing M rocks

Sample Input

25 5 2
2
14
11
21
17

Sample Output

4

Hint

Before removing any rocks, the shortest jump was a jump of 2 from 0 (the start) to 2. After removing the rocks at 2 and 14, the shortest required jump is a jump of 4 (from 17 to 21 or from 21 to 25).

Source


题解

同样是一个二分答案的题目,题意是讲,一个长度为L的河,有N个垫脚石,现在需要去掉m个垫脚石,使得两块石头之间的距离的最小值最大。把河的两岸也看做垫脚石,但是不能去掉他们。

和前几个题目一样,通过二分答案区间就行了。但是这个题目和前几道不同之处在于这个是修改搜索上界时更新res(前几道题都是修改下界时更新)。最后返回res即可。

写出来的效果就是代码示例中的那个样子了。

代码示例

/****
	*@author    Shen
	*@title     poj 1064
	*/

#include <cstdio>
#include <iostream>
#include <cmath>
#include <algorithm>
using namespace std;

int n, k;
int l, v[50005];
int maxa = 0;

bool test(int x)
{
    int sum = 0, st = 0;
    for (int i = 1; i <= n + 1; i++)
    {
        if (v[i] - v[st] <= x)
            sum++;
        else
            st = i;
    }
    //printf("\t%s with x = %d, result is that sum = %d.\n", __func__, x, sum);
    return sum <= k;
}

int Bsearch(int l, int r)
{
    int res = r;
    while (l <= r)
    {
        int mid = (r + l) / 2;
        //printf("l = %d, r = %d, mid = %d, res = %d.\n", l, r, mid, res);
        if (test(mid))
             l = mid + 1;
        else
            res = min(res, mid), r = mid - 1;
    }
    return res;
}

void solve()
{
    maxa = l;
    v[0] = 0;
    for (int i = 1; i <= n; i++)
    {
        scanf("%d", &l);
        v[i] = l;
    }
    v[n + 1] = maxa;
    sort(v, v + n + 2);
    int ans = Bsearch(0, maxa);
    printf("%d\n", ans);
}

int main()
{
    while (~scanf("%d%d%d",&l, &n, &k))
        solve();
    return 0;
}

POJ 3258 River Hopscotch 二分答案,布布扣,bubuko.com

POJ 3258 River Hopscotch 二分答案

标签:acm   c++   poj   二分   

原文地址:http://blog.csdn.net/polossk/article/details/25426183

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!