码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1076(Forwards on Weibo)

时间:2014-05-10 04:50:24      阅读:403      评论:0      收藏:0      [点我收藏+]

标签:advance pat   基础题   bfs   

Pat1076代码

题目描述:

Weibo is known as the Chinese version of Twitter. One user on Weibo may have many followers, and may follow many other users as well. Hence a social network is formed with followers relations. When a user makes a post on Weibo, all his/her followers can view and forward his/her post, which can then be forwarded again by their followers. Now given a social network, you are supposed to calculate the maximum potential amount of forwards for any specific user, assuming that only L levels of indirect followers are counted.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 positive integers: N (<=1000), the number of users; and L (<=6), the number of levels of indirect followers that are counted. Hence it is assumed that all the users are numbered from 1 to N. Then N lines follow, each in the format:

M[i] user_list[i]

where M[i] (<=100) is the total number of people that user[i] follows; and user_list[i] is a list of the M[i] users that are followed by user[i]. It is guaranteed that no one can follow oneself. All the numbers are separated by a space.

Then finally a positive K is given, followed by K UserID‘s for query.

Output Specification:

For each UserID, you are supposed to print in one line the maximum potential amount of forwards this user can triger, assuming that everyone who can view the initial post will forward it once, and that only L levels of indirect followers are counted.

Sample Input:
7 3
3 2 3 4
0
2 5 6
2 3 1
2 3 4
1 4
1 5
2 2 6
Sample Output:
4
5

AC代码:
#include<cstdio>
#include<queue>
#define MAX 1005

using namespace std;

int relation[MAX][MAX];
int visited[MAX];

void Init(int n)
{
	int i,j;
	for(i=1;i<=n;i++)
		for(j=1;j<=n;j++)
			relation[i][j]=0;
}

int BFS(int n,int query,int l)
{
	queue<int> q;
	int count=0;
	int curlevel=0,endlevel=0;
	int i,j;
	for(i=1;i<=n;i++)
		visited[i]=0;
	q.push(query);
	visited[query]=1;
	endlevel=q.back();
	while(!q.empty())
	{
		i=q.front();
		q.pop();
		for(j=1;j<=n;j++)
		{
			if(relation[i][j]==1&&!visited[j])
			{
				count++;
				visited[j]=1;
				q.push(j);
			}
		}
		if(i==endlevel)
		{
			curlevel++;
			endlevel=q.back();
		}
		if(curlevel==l)
			break;
	}
	return count;
}

int main(int argc,char *argv[])
{
	int n,l;
	int i,j,k;
	scanf("%d%d",&n,&l);
	Init(n);
	for(i=1;i<=n;i++)
	{
		int index;
		scanf("%d",&k);
		for(j=1;j<=k;j++)
		{
			scanf("%d",&index);
			relation[index][i]=1;
		}
	}
	scanf("%d",&k);
	while(k--)
	{
		int query;
		scanf("%d",&query);
		int ret=BFS(n,query,l);
		printf("%d\n",ret);
	}

	return 0;
}
BFS层数计数问题;最后一个case居然跑了2200ms,差点就超时了;思路是BFS肯定没错。

Pat(Advanced Level)Practice--1076(Forwards on Weibo),布布扣,bubuko.com

Pat(Advanced Level)Practice--1076(Forwards on Weibo)

标签:advance pat   基础题   bfs   

原文地址:http://blog.csdn.net/cstopcoder/article/details/25422611

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!