码迷,mamicode.com
首页 > 其他好文 > 详细

SOJ 1017 Power of Cryptography 库函数精度

时间:2017-10-06 12:27:22      阅读:156      评论:0      收藏:0      [点我收藏+]

标签:ted   printf   ack   files   存在   sequence   acm   alt   ons   

Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

 

The Problem

Given an integer 技术分享 and an integer 技术分享 you are to write a program that determines 技术分享 , the positive 技术分享 root of p. In this problem, given such integers n and pp will always be of the form 技术分享 for an integer k (this integer is what your program must find).

 

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 技术分享 , 技术分享 and there exists an integer k技术分享 such that 技术分享 .

 

The Output

For each integer pair n and p the value 技术分享 should be printed, i.e., the number k such that 技术分享 .

 

Sample Input

 

2
16
3
27
7
4357186184021382204544

 

Sample Output

 

4
3
1234

解题思路:
  本题直接用pow求解就好,不过可能存在四舍五入一类的精度问题需要处理,所以要特别小心
AC代码:
#include<stdio.h>
#include<math.h>
int main()
{
    double p,k;
    double n;
    while(scanf("%lf%lf",&n,&p)==2)
    {
        k=  pow (p,1.0/n);
        long long ans=k;
        if(pow(ans,n)!=p)printf("%ld\n",ans+1);
        else printf("%ld\n",ans);
    }
    return 0;
} 

 

SOJ 1017 Power of Cryptography 库函数精度

标签:ted   printf   ack   files   存在   sequence   acm   alt   ons   

原文地址:http://www.cnblogs.com/87hbteo/p/7631289.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!