码迷,mamicode.com
首页 > 其他好文 > 详细

poj2420 A Star not a Tree?

时间:2017-10-08 10:04:21      阅读:157      评论:0      收藏:0      [点我收藏+]

标签:inf   compute   desc   app   use   log   network   target   nat   

A Star not a Tree?
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7684   Accepted: 3502

Description

Luke wants to upgrade his home computer network from 10mbs to 100mbs. His existing network uses 10base2 (coaxial) cables that allow you to connect any number of computers together in a linear arrangement. Luke is particulary proud that he solved a nasty NP-complete problem in order to minimize the total cable length. 
Unfortunately, Luke cannot use his existing cabling. The 100mbs system uses 100baseT (twisted pair) cables. Each 100baseT cable connects only two devices: either two network cards or a network card and a hub. (A hub is an electronic device that interconnects several cables.) Luke has a choice: He can buy 2N-2 network cards and connect his N computers together by inserting one or more cards into each computer and connecting them all together. Or he can buy N network cards and a hub and connect each of his N computers to the hub. The first approach would require that Luke configure his operating system to forward network traffic. However, with the installation of Winux 2007.2, Luke discovered that network forwarding no longer worked. He couldn‘t figure out how to re-enable forwarding, and he had never heard of Prim or Kruskal, so he settled on the second approach: N network cards and a hub. 

Luke lives in a loft and so is prepared to run the cables and place the hub anywhere. But he won‘t move his computers. He wants to minimize the total length of cable he must buy.

Input

The first line of input contains a positive integer N <= 100, the number of computers. N lines follow; each gives the (x,y) coordinates (in mm.) of a computer within the room. All coordinates are integers between 0 and 10,000.

Output

Output consists of one number, the total length of the cable segments, rounded to the nearest mm.

Sample Input

4
0 0
0 10000
10000 10000
10000 0

Sample Output

28284

题意: 求平面上一点,到其它点的距离最小
模拟退火第一题
#include<cstdio>
#include<cmath>
#define N 101

#define eps 1e-8
#define delta 0.98
#define T 100
#define INF 1e20;

using namespace std;

int dx[4]={-1,0,1,0};
int dy[4]={0,1,0,-1};
int n;

struct Point
{
    double x,y;
};
Point p[N];

double dist(Point A,Point B)
{
    return sqrt((A.x-B.x)*(A.x-B.x)+(A.y-B.y)*(A.y-B.y));
}

double getsum(Point z)
{
    double ans=0;
    for(int i=1;i<=n;i++) ans+=dist(p[i],z);
    return ans;
}

double search()
{
    Point s=p[1];
    double t=T;
    double ans=INF;
    while(t>eps)
    {
        bool flag=true;
        while(flag)
        {
            flag=false;
            for(int i=0;i<4;i++)
            {
                Point z;
                z.x=s.x+dx[i]*t;
                z.y=s.y+dy[i]*t;
                double tp=getsum(z);
                if(ans>tp)
                {
                    ans=tp;
                    s=z;
                    flag=true;
                }
            }
        }
        t*=delta;
    }
    return ans;
}

int main()
{
    scanf("%d",&n);
    for(int i=1;i<=n;i++) scanf("%lf%lf",&p[i].x,&p[i].y);
    printf("%.0lf",search());
}

 

poj2420 A Star not a Tree?

标签:inf   compute   desc   app   use   log   network   target   nat   

原文地址:http://www.cnblogs.com/TheRoadToTheGold/p/7636550.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!