码迷,mamicode.com
首页 > 其他好文 > 详细

1012. The Best Rank (25)

时间:2017-10-14 14:35:21      阅读:158      评论:0      收藏:0      [点我收藏+]

标签:lan   string   blog   one   mes   cal   sim   name   lin   

To evaluate the performance of our first year CS majored students, we consider their grades of three courses only: C - C Programming Language, M - Mathematics (Calculus or Linear Algebra), and E - English. At the mean time, we encourage students by emphasizing on their best ranks -- that is, among the four ranks with respect to the three courses and the average grade, we print the best rank for each student.

For example, The grades of C, M, E and A - Average of 4 students are given as the following:

StudentID  C  M  E  A
310101     98 85 88 90
310102     70 95 88 84
310103     82 87 94 88
310104     91 91 91 91

Then the best ranks for all the students are No.1 since the 1st one has done the best in C Programming Language, while the 2nd one in Mathematics, the 3rd one in English, and the last one in average.

Input

Each input file contains one test case. Each case starts with a line containing 2 numbers N and M (<=2000), which are the total number of students, and the number of students who would check their ranks, respectively. Then N lines follow, each contains a student ID which is a string of 6 digits, followed by the three integer grades (in the range of [0, 100]) of that student in the order of C, M and E. Then there are M lines, each containing a student ID.

Output

For each of the M students, print in one line the best rank for him/her, and the symbol of the corresponding rank, separated by a space.

The priorities of the ranking methods are ordered as A > C > M > E. Hence if there are two or more ways for a student to obtain the same best rank, output the one with the highest priority.

If a student is not on the grading list, simply output "N/A".

Sample Input
5 6
310101 98 85 88
310102 70 95 88
310103 82 87 94
310104 91 91 91
310105 85 90 90
310101
310102
310103
310104
310105
999999
Sample Output
1 C
1 M
1 E
1 A
3 A
N/A


题意是对四个成绩进行排名,c语言,数学,英语,以及三门的平均分(只需要把三门加起来存到结构体即可,反正都要除以三)。用sort,自己写了个cmp函数,排名需要特别注意的一点,成绩相同的名次也相同,
就是说比如88 87 87 55,对应名次为1,2,2,4。


代码:
#include <iostream>
#include <map>
#include <algorithm>
using namespace std;
int w = 1;
struct stu
{
    string id;
    int c,m,e,a;
    int cc,mm,ee,aa;
}s[2001];
bool cmp(stu a,stu b)
{
    if(w == 1)return a.c>b.c;
    else if(w == 2)return a.m>b.m;
    else if(w == 3)return a.e>b.e;
    else return a.a>b.a;
}
void print(stu a)
{
    char ch = A;
    int d = a.aa;
    if(d > a.cc)ch = C,d = a.cc;
    if(d > a.mm)ch = M,d = a.mm;
    if(d > a.ee)ch = E,d = a.ee;
    cout<<d<< <<ch<<endl;
}
int main()
{
    int n,m;
    string p;
    map<string,int> match;
    cin>>n>>m;
    for(int i = 0;i < n;i ++)
    {
        cin>>s[i].id>>s[i].c>>s[i].m>>s[i].e;
        s[i].a = s[i].c + s[i].m + s[i].e;
    }
//    for(int i = 0;i < n;i ++)
//    {
//        cout<<s[i].id<<‘ ‘<<s[i].a<<endl;
//    }
    sort(s,s+n,cmp);
    for(int i = 0;i < n;i ++)
    {
        if(i > 0 && s[i].c == s[i - 1].c)s[i].cc = s[i - 1].cc;
        else s[i].cc = i + 1;
    }
    w = 2;
    sort(s,s+n,cmp);
    for(int i = 0;i < n;i ++)
    {
        if(i > 0 && s[i].m == s[i - 1].m)s[i].mm = s[i - 1].mm;
        else s[i].mm = i + 1;
    }
    w = 3;
    sort(s,s+n,cmp);
    for(int i = 0;i < n;i ++)
    {
        if(i > 0 && s[i].e == s[i - 1].e)s[i].ee = s[i - 1].ee;
        else s[i].ee = i + 1;
    }
    w = 4;
    sort(s,s+n,cmp);
    for(int i = 0;i < n;i ++)
    {
        if(i > 0 && s[i].a == s[i - 1].a)s[i].aa = s[i - 1].aa;
        else s[i].aa = i + 1;
        match[s[i].id] = i + 1;
    }
    for(int i = 0;i < m;i ++)
    {
        cin>>p;
        if(match[p])print(s[match[p] - 1]);
        else cout<<"N/A"<<endl;
    }
}

 

1012. The Best Rank (25)

标签:lan   string   blog   one   mes   cal   sim   name   lin   

原文地址:http://www.cnblogs.com/8023spz/p/7666883.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!