码迷,mamicode.com
首页 > 其他好文 > 详细

2015北京区域赛 Xiongnu's Land

时间:2017-11-01 12:18:29      阅读:214      评论:0      收藏:0      [点我收藏+]

标签:follow   with   return   否则   cst   std   bin   ini   ret   

Wei Qing (died 106 BC) was a military general of the Western Han dynasty whose campaigns against 
the Xiongnu earned him great acclaim. He was a relative of Emperor Wu because he was the younger 
half-brother of Empress Wei Zifu (Emperor Wu’s wife) and the husband of Princess Pingyang. He was 
also the uncle of Huo Qubing, another notable Han general who participated in the campaigns against 
the Xiongnu and exhibited outstanding military talent even as a teenager. 
Defeated by Wei Qing and Huo Qubing, the Xiongnu sang: “Losing my Qilian Mountains, made 
my cattle unthriving; Losing my Yanzhi Mountains, made my women lacking rouge.” 
The text above is digested from Wikipedia. Since Wei and Huo’s distinguished achievements, 
Emperor Wu decided to give them some awards — a piece of land taken by them from Xiongnu. This 
piece of land was located in a desert, and there were many oases in it. Emperor Wu wanted to draw 
a straight south-to-north dividing line to divide the land into two parts, and gave the western part to 
Wei Qing while gave the eastern part to Huo Qubing. There are two rules about the land dividing: 
1. The total area of the oases lay in Wei’s land must be larger or equal to the total area of the oases 
lay in Huo’s land, and the difference must be as small as possible. 
2. Emperor Wu wanted Wei’s land to be as large as possible without violating the rule 1. 
To simplify the problem, please consider the piece of land given to Wei and Huo as a square on a 
plane. The coordinate of its left bottom corner was (0,0) and the coordinate of its right top corner 
was (R, R). Each oasis in this land could also be considered as a rectangle which was parallel to the 
coordinate axes. The equation of the dividing line was like x = n, and n must be an integer. If the 
dividing line split an oasis, then Wei owned the western part and Huo owned the eastern part. Please 
help Emperor Wu to find out how to draw the dividing line. 
Input 
The first line of the input is an integer K meaning that there are K (1 ≤ K ≤ 15) test cases. 
For each test case: 
The first line is an integer R, indicating that the land’s right top corner was at (R, R) (1 ≤ R ≤ 
1,000,000) 
Then a line containing an integer N follows, indicating that there were N (0 < N ≤ 10000) oases. 
Then N lines follow, each contains four integers L, T, W and H, meaning that there was an 
oasis whose coordinate of the left top corner was (L, T), and its width was W and height was H. 
(0 ≤ L, T ≤ R, 0 < W, H ≤ R). No oasis overlaps. 
Output 
For each test case, print an integer n, meaning that Emperor Wu should draw a dividing line whose 
equation is x = n. Please note that, in order to satisfy the rules, Emperor might let Wei get the whole 
land by drawing a line of x = R if he had to. 
Sample Input 

1000 

1 1 2 1 
5 1 2 1 
1000 

1 1 2 1 
Sample Output 

2

题意:沙漠中有许多块矩形水源,水源不相交,问能否找到一根中轴线,使得轴线左边的水源面积大于等于右边的水源面积。在满足两个面积之差最小的情况下,使得轴线靠近右端点

 

用二分法求,否则时间超限

#include<cstdio>
#include<iostream>
#include<algorithm>
using namespace std;
typedef long long ll;
int n;
struct point{
    int x,y,w,h;
};
point a[10010];
/*bool cmp(point p,point q){
    return p.x<q.x;
}*/
ll cal(int x){
    ll sum = 0;
    for(int i=0;i<n;i++){
        if(a[i].x < x){
            sum += (ll)( min( (a[i].w+a[i].x),x) - a[i].x) * a[i].h; 
        }
    }
    return sum;
}
int main(){
    int T,R,w,h;
    ll total;
    while(cin >> T){
        while(T--){
            total = 0;
            cin >> R;
            cin >> n;
            for(int i=0;i<n;i++){
                cin >> a[i].x >> a[i].y >> a[i].w >> a[i].h;
                total += (ll)a[i].h*a[i].w;//注意每次都要取long long 否则答案错误
                        
            }    
        //    sort(a,a+n,cmp);
            int l,r,mid;
            ll tmp;
            l = 0,r = R;
            while(l<r){
                mid = (r+l)/2;
                tmp = cal(mid);
                if(2*tmp<total){
                    l = mid + 1;
                }else r = mid;
            }
            tmp = cal(r);
            while(cal(r) == tmp && r<=R){
                r ++;
            }
            cout << r-1 << endl;
        }
    }
    return 0; 
}
    

 

2015北京区域赛 Xiongnu's Land

标签:follow   with   return   否则   cst   std   bin   ini   ret   

原文地址:http://www.cnblogs.com/l609929321/p/7765454.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!