码迷,mamicode.com
首页 > 其他好文 > 详细

1051. Pop Sequence (25)

时间:2017-11-04 16:19:50      阅读:150      评论:0      收藏:0      [点我收藏+]

标签:contains   dom   capacity   top   ++   cpp   sam   log   ber   

Given a stack which can keep M numbers at most. Push N numbers in the order of 1, 2, 3, ..., N and pop randomly. You are supposed to tell if a given sequence of numbers is a possible pop sequence of the stack. For example, if M is 5 and N is 7, we can obtain 1, 2, 3, 4, 5, 6, 7 from the stack, but not 3, 2, 1, 7, 5, 6, 4.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 numbers (all no more than 1000): M (the maximum capacity of the stack), N (the length of push sequence), and K (the number of pop sequences to be checked). Then K lines follow, each contains a pop sequence of N numbers. All the numbers in a line are separated by a space.

Output Specification:

For each pop sequence, print in one line "YES" if it is indeed a possible pop sequence of the stack, or "NO" if not.

Sample Input:

5 7 5
1 2 3 4 5 6 7
3 2 1 7 5 6 4
7 6 5 4 3 2 1
5 6 4 3 7 2 1
1 7 6 5 4 3 2

Sample Output:

YES
NO
NO
YES
NO

题目大意:就是以1、2、3......N的值依次入栈,随机出栈,判断所给的序列是否是正确的出栈序列。

#include<iostream>
#include<cstdio>
#include<stack>
#include<queue>
using namespace std;
int main(){
	int m,n,k;
	scanf("%d%d%d",&m,&n,&k);
	int i,j;
	int qval;
	while(k--){
		int sval=1;
		stack<int>s;
		queue<int>q;
		for(i=0;i<n;i++){
			scanf("%d",&qval);
			q.push(qval);
		}
		while(!q.empty()){
			qval=q.front();
			for(i=sval;i<=qval;i++){
				s.push(i);
			}
			sval=i;
			if(s.size()>m){
				break;
			}
			while(!s.empty()&&!q.empty()){
				if(s.top()==q.front()){
					s.pop();
					q.pop();
				}else{
					break;
				}
			}
			if(!s.empty()&&!q.empty()&&s.top()>q.front()){
				break;
			}
		}
		if(!q.empty()){
			printf("NO\n");
		}else {
			printf("YES\n");
		}
	}
	return 0;
} 

  

1051. Pop Sequence (25)

标签:contains   dom   capacity   top   ++   cpp   sam   log   ber   

原文地址:http://www.cnblogs.com/grglym/p/7783356.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!