码迷,mamicode.com
首页 > 其他好文 > 详细

poj1753Flip Game【刷题计划】

时间:2017-11-04 20:43:56      阅读:186      评论:0      收藏:0      [点我收藏+]

标签:tom   otto   word   ons   red   mis   top   aced   line   

 

Flip Game
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 47766   Accepted: 20383

Description

Flip game is played on a rectangular 4x4 field with two-sided pieces placed on each of its 16 squares. One side of each piece is white and the other one is black and each piece is lying either it‘s black or white side up. Each round you flip 3 to 5 pieces, thus changing the color of their upper side from black to white and vice versa. The pieces to be flipped are chosen every round according to the following rules: 
  1. Choose any one of the 16 pieces. 
  2. Flip the chosen piece and also all adjacent pieces to the left, to the right, to the top, and to the bottom of the chosen piece (if there are any).

技术分享Consider the following position as an example: 

bwbw 
wwww 
bbwb 
bwwb 
Here "b" denotes pieces lying their black side up and "w" denotes pieces lying their white side up. If we choose to flip the 1st piece from the 3rd row (this choice is shown at the picture), then the field will become: 

bwbw 
bwww 
wwwb 
wwwb 
The goal of the game is to flip either all pieces white side up or all pieces black side up. You are to write a program that will search for the minimum number of rounds needed to achieve this goal. 

Input

The input consists of 4 lines with 4 characters "w" or "b" each that denote game field position.

Output

Write to the output file a single integer number - the minimum number of rounds needed to achieve the goal of the game from the given position. If the goal is initially achieved, then write 0. If it‘s impossible to achieve the goal, then write the word "Impossible" (without quotes).

Sample Input

bwwb
bbwb
bwwb
bwww

Sample Output

4

题意:把一个4*4的棋盘翻转为颜色统一,翻转规则是翻转一个棋子时,这个棋子上下左右也要进行翻转。

 

思路:枚举。递归真是横贯搜索啊 ~~用好了真心感觉神奇,今天又重新写了一下之前写的这道题,发现又有了新的大陆。

 

#include<stdio.h>
#include<string.h>
#define inf 0x3f3f3f3f
int flag,min,map[4][4];
int CheckMap(int map[][4])
{
    for(int i = 0; i < 4; i ++)
        for(int j = 0; j < 4; j ++)
            if(map[i][j] != map[0][0])
            return 0;
    return 1;
}
void Reverse(int ans)
{
    int k[4][2] = {0,1,0,-1,-1,0,1,0};
    int x = ans/4;
    int y = ans%4;
    map[x][y] ^= 1;
    for(int i = 0; i< 4; i ++)
    {
        x = ans/4 + k[i][0];
        y = ans%4 + k[i][1];
        if(x < 0||y < 0||x > 3||y > 3)
            continue;
        map[x][y] ^= 1;
    }
    return;
}
void dfs(int ans,int step)
{
    if(CheckMap(map))
    {
        flag = 1;
        if(step < min)
            min = step;
        return;
    }
    if(ans == 16)
        return;
    dfs(ans+1,step);//不翻转当前棋子 
    Reverse(ans);//翻转当前棋子 
    dfs(ans+1,step+1);//翻转当前棋子步数+1,往下搜索 
    Reverse(ans);    //复原 
}
int main()
{
    
    char str[4][4];
    flag = 0;
    min = inf;
    for(int i = 0; i < 4; i ++)
    {
        for(int j = 0; j < 4; j ++)
        {
            scanf("%c",&str[i][j]);
            if(str[i][j] == b)
                map[i][j] = 1;
            else 
                map[i][j] = 0;
        }
        getchar();
    }
    dfs(0,0);
    if(!flag)
        printf("Impossible\n");
    else
        printf("%d\n",min);
    return 0;
}

 

poj1753Flip Game【刷题计划】

标签:tom   otto   word   ons   red   mis   top   aced   line   

原文地址:http://www.cnblogs.com/chengdongni/p/7784350.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!