码迷,mamicode.com
首页 > 其他好文 > 详细

pat1008

时间:2017-11-07 19:50:47      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:cost   specific   input   cond   and   sts   stream   elevator   for   

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100.

Output Specification:

For each test case, print the total time on a single line.

Sample Input:

3 2 3 1

Sample Output:

41
模拟。。先到2楼再到3楼再到1楼
#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
int a[105];
int main()
{
    int n;
    while(cin>>n)
    {
        memset(a,0,sizeof(a));
        a[0]=0;
        int ans=5*n;
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
        }
        for(int i=1;i<=n;i++)
        {
            if(a[i]>a[i-1])
                ans+=6*(a[i]-a[i-1]);
            else if(a[i]<a[i-1])
                ans+=4*(a[i-1]-a[i]);
        }
        cout<<ans<<endl;
    }
    return 0;
}

 


提交代码

pat1008

标签:cost   specific   input   cond   and   sts   stream   elevator   for   

原文地址:http://www.cnblogs.com/2014slx/p/7800159.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!