码迷,mamicode.com
首页 > 其他好文 > 详细

【BZOJ2175】旅游(树链剖分,Link-Cut Tree)

时间:2017-11-18 23:35:08      阅读:203      评论:0      收藏:0      [点我收藏+]

标签:--   getch   logs   练习   包含   美丽   out   algo   cto   

【BZOJ2175】旅游(树链剖分,Link-Cut Tree)

题面

Description

Ray 乐忠于旅游,这次他来到了T 城。T 城是一个水上城市,一共有 N 个景点,有些景点之间会用一座桥连接。为了方便游客到达每个景点但又为了节约成本,T 城的任意两个景点之间有且只有一条路径。换句话说, T 城中只有N ? 1 座桥。Ray 发现,有些桥上可以看到美丽的景色,让人心情愉悦,但有些桥狭窄泥泞,令人烦躁。于是,他给每座桥定义一个愉悦度w,也就是说,Ray 经过这座桥会增加w 的愉悦度,这或许是正的也可能是负的。有时,Ray 看待同一座桥的心情也会发生改变。现在,Ray 想让你帮他计算从u 景点到v 景点能获得的总愉悦度。有时,他还想知道某段路上最美丽的桥所提供的最大愉悦度,或是某段路上最糟糕的一座桥提供的最低愉悦度。

Input

输入的第一行包含一个整数N,表示T 城中的景点个数。景点编号为 0...N ? 1。接下来N ? 1 行,每行三个整数u、v 和w,表示有一条u 到v,使 Ray 愉悦度增加w 的桥。桥的编号为1...N ? 1。|w| <= 1000。输入的第N + 1 行包含一个整数M,表示Ray 的操作数目。接下来有M 行,每行描述了一个操作,操作有如下五种形式: C i w,表示Ray 对于经过第i 座桥的愉悦度变成了w。 N u v,表示Ray 对于经过景点u 到v 的路径上的每一座桥的愉悦度都变成原来的相反数。 SUM u v,表示询问从景点u 到v 所获得的总愉悦度。 MAX u v,表示询问从景点u 到v 的路径上的所有桥中某一座桥所提供的最大愉悦度。 MIN u v,表示询问从景点u 到v 的路径上的所有桥中某一座桥所提供的最小愉悦度。测试数据保证,任意时刻,Ray 对于经过每一座桥的愉悦度的绝对值小于等于1000。

Output

对于每一个询问(操作S、MAX 和MIN),输出答案。

Sample Input

3

0 1 1

1 2 2

8

SUM 0 2

MAX 0 2

N 0 1

SUM 0 2

MIN 0 2

C 1 3

SUM 0 2

MAX 0 2

Sample Output

3

2

1

-1

5

3

HINT

一共有10 个数据,对于第i (1 <= i <= 10) 个数据, N = M = i * 2000。

题解

又不要修改边的连接,
用什么\(LCT\)
不是直接搞一个树链剖分就可以了吗?
多简单

但是我就是手贱而已。。。
我就要用\(LCT\)来做
(其实是练习一下\(LCT\)嗷)

反正,之前说过
\(LCT\)维护边权的方法是把边单独拆开作为一个点来看待
那么,直接维护一下就好啦。

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<cmath>
#include<algorithm>
#include<set>
#include<map>
#include<vector>
#include<queue>
using namespace std;
#define MAX 21000
#define INF (1000000000)
#define lson (t[x].ch[0])
#define rson (t[x].ch[1])
inline int read()
{
    int x=0,t=1;char ch=getchar();
    while((ch<'0'||ch>'9')&&ch!='-')ch=getchar();
    if(ch=='-')t=-1,ch=getchar();
    while(ch<='9'&&ch>='0')x=x*10+ch-48,ch=getchar();
    return x*t;
}
struct Node
{
    int ff,ch[2];
    int sum,ma,mi,w;
    int rev;
    void init(int W)
    {
        mi=ma=w=sum=W;
    }
}t[MAX<<1]; 
int S[MAX<<1],top;
int n;
inline bool isroot(int x){return t[t[x].ff].ch[0]!=x&&t[t[x].ff].ch[1]!=x;}
inline void pushdown(int x)
{
    if(!t[x].rev)return;
    swap(lson,rson);
    t[lson].rev^=1;
    t[rson].rev^=1;
    t[x].rev^=1;
}
inline void pushup(int x)
{
    t[x].init(t[x].w);
    t[x].sum=t[lson].sum+t[rson].sum+t[x].w;
    if(x<=n)t[x].mi=INF,t[x].ma=-INF;
    t[x].mi=min(t[x].mi,min(t[lson].mi,t[rson].mi));
    t[x].ma=max(t[x].ma,max(t[lson].ma,t[rson].ma));
}
void rotate(int x)
{
    int y=t[x].ff,z=t[y].ff;
    int k=t[y].ch[1]==x;
    if(!isroot(y))t[z].ch[t[z].ch[1]==y]=x;t[x].ff=z;
    t[y].ch[k]=t[x].ch[k^1];t[t[x].ch[k^1]].ff=y;
    t[x].ch[k^1]=y;t[y].ff=x;
    pushup(y);pushup(x);
}
void Splay(int x)
{
    S[top=1]=x;
    for(int i=x;!isroot(i);i=t[i].ff)S[++top]=t[i].ff;
    while(top)pushdown(S[top--]);
    while(!isroot(x))
    {
        int y=t[x].ff,z=t[y].ff;
        if(!isroot(y))
            (t[z].ch[0]==y)^(t[y].ch[0]==x)?rotate(x):rotate(y);
        rotate(x);
    }
}
void access(int x){for(int y=0;x;y=x,x=t[x].ff)Splay(x),t[x].ch[1]=y,pushup(x);}
void makeroot(int x){access(x);Splay(x);t[x].rev^=1;}
void split(int x,int y){makeroot(x);access(y);Splay(y);}
void cut(int x,int y){split(x,y);t[y].ch[0]=t[x].ff=0;pushup(y);}
void link(int x,int y){makeroot(x);t[x].ff=y;}
void N(int x)
{
    if(lson)N(lson);
    if(rson)N(rson);
    t[x].init(-t[x].w);
    pushup(x);
}
int main()
{
    n=read();
    t[0].mi=INF;t[0].ma=-INF;
    for(int i=1,u,v;i<n;++i)
    {
        u=read()+1;v=read()+1;
        t[i+n].w=read();t[i+n].init(t[i+n].w);
        link(u,i+n);link(v,i+n);
    }   
    int m=read();
    char ch[10];
    while(m--)
    {
        scanf("%s",ch);
        if(ch[0]=='C')
        {
            int k=read(),W=read();
            makeroot(k+n);
            t[k+n].init(W);
        }
        else if(ch[0]=='N')
        {
            int x=read()+1,y=read()+1;
            split(x,y);
            N(y);
        }
        else if(ch[0]=='S')
        {
            int x=read()+1,y=read()+1;
            split(x,y);
            printf("%d\n",t[y].sum);
        }
        else if(ch[1]=='A')
        {
            int x=read()+1,y=read()+1;
            split(x,y);
            printf("%d\n",t[y].ma);
        }
        else
        {
            int x=read()+1,y=read()+1;
            split(x,y);
            printf("%d\n",t[y].mi);
        }
    }
    return 0;
}

【BZOJ2175】旅游(树链剖分,Link-Cut Tree)

标签:--   getch   logs   练习   包含   美丽   out   algo   cto   

原文地址:http://www.cnblogs.com/cjyyb/p/7858240.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!