码迷,mamicode.com
首页 > 其他好文 > 详细

HDU5012:Dice(bfs模板)

时间:2014-09-14 20:35:37      阅读:269      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   ar   for   

http://acm.hdu.edu.cn/showproblem.php?pid=5012

Problem Description
There are 2 special dices on the table. On each face of the dice, a distinct number was written. Consider a1.a2,a3,a4,a5,a6 to be numbers written on top face, bottom face, left face, right face, front face and back face of dice A. Similarly, consider b1.b2,b3,b4,b5,b6 to be numbers on specific faces of dice B. It’s guaranteed that all numbers written on dices are integers no smaller than 1 and no more than 6 while ai ≠ aj and bi ≠ bj for all i ≠ j. Specially, sum of numbers on opposite faces may not be 7.

At the beginning, the two dices may face different(which means there exist some i, ai ≠ bi). Ddy wants to make the two dices look the same from all directions(which means for all i, ai = bi) only by the following four rotation operations.(Please read the picture for more information)

bubuko.com,布布扣

Now Ddy wants to calculate the minimal steps that he has to take to achieve his goal.
 
Input
There are multiple test cases. Please process till EOF.

For each case, the first line consists of six integers a1,a2,a3,a4,a5,a6, representing the numbers on dice A.

The second line consists of six integers b1,b2,b3,b4,b5,b6, representing the numbers on dice B.
 
Output
For each test case, print a line with a number representing the answer. If there’s no way to make two dices exactly the same, output -1.
 
Sample Input
1 2 3 4 5 6
1 2 3 4 5 6
1 2 3 4 5 6
1 2 5 6 4 3
1 2 3 4 5 6
1 4 2 5 3 6
 
Sample Output
0
3
-1
Source
题目解析:因为是网络赛没看题就觉得是几何题,觉得做不了,之后看交的多了,就看了一下题,没想到是bfs模板水题。
#include <iostream>
#include <stdio.h>
#include <stdlib.h>
#include <string.h>
#include <queue>
using namespace std;
int v[7][7][7][7][7][7];
struct node
{
    int ff[7];
    int ans;
};
struct node t,f;
int a[7],b[7];
int bfs()
{
    queue<node>q;
    for(int i=1; i<=6; i++)
        t.ff[i]=a[i];
    t.ans=0;
    q.push(t);
    v[t.ff[1]][t.ff[2]][t.ff[3]][t.ff[4]][t.ff[5]][t.ff[6]]=1;
    while(!q.empty())
    {
        t=q.front();
        q.pop();
        if(t.ff[1]==b[1]&&t.ff[2]==b[2]&&t.ff[3]==b[3]&&t.ff[4]==b[4]&&t.ff[5]==b[5]&&t.ff[6]==b[6])
        {
            printf("%d\n",t.ans);
            return 1;
        }
        for(int i=1; i<=4; i++)
        {
            if(i==1)
            {
                f.ff[1]=t.ff[4];
                f.ff[2]=t.ff[3];
                f.ff[3]=t.ff[1];
                f.ff[4]=t.ff[2];
                f.ff[5]=t.ff[5];
                f.ff[6]=t.ff[6];
                if(v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]==0)
                {
                    f.ans=t.ans+1;
                    v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]=1;
                    q.push(f);
                }
            }
            else if(i==2)
            {
                f.ff[1]=t.ff[3];
                f.ff[2]=t.ff[4];
                f.ff[3]=t.ff[2];
                f.ff[4]=t.ff[1];
                f.ff[5]=t.ff[5];
                f.ff[6]=t.ff[6];
                if(v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]==0)
                {
                    f.ans=t.ans+1;
                    v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]=1;
                    q.push(f);
                }
            }
            else if(i==3)
            {
                f.ff[1]=t.ff[6];
                f.ff[2]=t.ff[5];
                f.ff[3]=t.ff[3];
                f.ff[4]=t.ff[4];
                f.ff[5]=t.ff[1];
                f.ff[6]=t.ff[2];
                if(v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]==0)
                {
                    f.ans=t.ans+1;
                    v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]=1;
                    q.push(f);
                }
            }
            else if(i==4)
            {
                f.ff[1]=t.ff[5];
                f.ff[2]=t.ff[6];
                f.ff[3]=t.ff[3];
                f.ff[4]=t.ff[4];
                f.ff[5]=t.ff[2];
                f.ff[6]=t.ff[1];
                if(v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]==0)
                {
                    f.ans=t.ans+1;
                    v[f.ff[1]][f.ff[2]][f.ff[3]][f.ff[4]][f.ff[5]][f.ff[6]]=1;
                    q.push(f);
                }
            }
        }
    }
    return 0;
}
int main()
{
    int F;
    while(scanf("%d%d%d%d%d%d",&a[1],&a[2],&a[3],&a[4],&a[5],&a[6])!=EOF)
    {
        for(int i=1; i<=6; i++)
            scanf("%d",&b[i]);
        memset(v,0,sizeof(v));
        F=bfs();
        if(F==0) printf("-1\n");
    }
    return 0;
}

 

 

HDU5012:Dice(bfs模板)

标签:des   style   blog   http   color   io   os   ar   for   

原文地址:http://www.cnblogs.com/zhangmingcheng/p/3971406.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!