码迷,mamicode.com
首页 > 其他好文 > 详细

POJ 2376 Cleaning Shifts (贪心)

时间:2017-11-19 11:05:32      阅读:106      评论:0      收藏:0      [点我收藏+]

标签:john   job   wan   val   ant   cin   struct   each   void   

Farmer John is assigning some of his N (1 <= N <= 25,000) cows to do some cleaning chores around the barn. He always wants to have one cow working on cleaning things up and has divided the day into T shifts (1 <= T <= 1,000,000), the first being shift 1 and the last being shift T.

Each cow is only available at some interval of times during the day for work on cleaning. Any cow that is selected for cleaning duty will work for the entirety of her interval.

Your job is to help Farmer John assign some cows to shifts so that (i) every shift has at least one cow assigned to it, and (ii) as few cows as possible are involved in cleaning. If it is not possible to assign a cow to each shift, print -1.
Input

  • Line 1: Two space-separated integers: N and T

  • Lines 2..N+1: Each line contains the start and end times of the interval during which a cow can work. A cow starts work at the start time and finishes after the end time.
    Output
  • Line 1: The minimum number of cows Farmer John needs to hire or -1 if it is not possible to assign a cow to each shift.
    Sample Input
    3 10
    1 7
    3 6
    6 10
    Sample Output
    2
    Hint
    This problem has huge input data,use scanf() instead of cin to read data to avoid time limit exceed.

INPUT DETAILS:

There are 3 cows and 10 shifts. Cow #1 can work shifts 1..7, cow #2 can work shifts 3..6, and cow #3 can work shifts 6..10.

OUTPUT DETAILS:

By selecting cows #1 and #3, all shifts are covered. There is no way to cover all the shifts using fewer than 2 cows.

题意:

给出n个区间,问至少需要多少个区间能够完全覆盖[1,T]的区间。

题解:

选取下一个区间的时候,尽量选取那些能转移右端最长的区间。

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
const int maxn=3e4;
struct shift
{
    int beg,end;
    bool operator <(const shift& a) const
    {
        return beg==a.beg?end>a.end:beg<a.beg;
    }
}a[maxn];
int main()
{
    int n,t;
    scanf("%d%d",&n,&t);
    for(int i=0;i<n;i++)
    {
        scanf("%d%d",&a[i].beg,&a[i].end);
    }
    sort(a,a+n);
    int cur=0;
    int l=0;
    int ans=0;
    while(cur<n)
    {
        if(a[cur].beg>l+1)
            return puts("-1");
        int tmp=1;
        while(cur<n&&a[cur].beg<=l+1)
        {
            tmp=max(tmp,a[cur].end);
            cur++;
        }
        l=tmp;
        ans++;
        if(l>=t)
            return printf("%d\n",ans);
    }
    return puts("-1");
}

POJ 2376 Cleaning Shifts (贪心)

标签:john   job   wan   val   ant   cin   struct   each   void   

原文地址:http://www.cnblogs.com/orion7/p/7859178.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!