码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 5014 Number Sequence(异或 进制问题)

时间:2014-09-14 22:10:27      阅读:387      评论:0      收藏:0      [点我收藏+]

标签:hdu   二进制   异或   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=5014




Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:
● ai ∈ [0,n] 
● ai ≠ aj( i ≠ j )
For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):
t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)
(sequence B should also satisfy the rules described above)
Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
Input
There are multiple test cases. Please process till EOF. 
For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0 ≤ i ≤ n - 1). Don’t ouput any spaces after bn.

Sample Input
4 2 0 1 4 3
 
Sample Output
20 1 0 2 3 4
 
Source


思路:

尽可能找2^x-1,智商真是捉急啊!

最终可以全部异或为11111……(二进制位全是1)

所以最终的异或的和就是n*(n+1);


代码如下:

#include <cstdio>
#include <cstring>
#define MAXN 100017
typedef __int64 LL;
int a[MAXN], vis[MAXN];
int main()
{
    LL n;
    while(~scanf("%I64d",&n))
    {
        memset(vis,-1,sizeof(vis));
        for(int i = 0; i <= n; i++)
        {
            scanf("%d",&a[i]);
        }
        int m = 1;
        while(m < n)//2^x-1
        {
            m = m*2+1;
        }
        for(int i = n; i >= 0; i--)
        {
            if(i <= m/2)
                m/=2;
            if(vis[i] == -1)
            {
                vis[i] = i^m;
                vis[i^m] = i;
            }
        }
        LL ans = n*(n+1);
        printf("%I64d\n",ans);
        for(int i = 0; i < n; i++)
        {
            printf("%d ",vis[a[i]]);
        }
        printf("%d\n",vis[a[n]]);
    }
    return 0;
}


Problem Description
There is a special number sequence which has n+1 integers. For each number in sequence, we have two rules:

● ai ∈ [0,n] 
● ai ≠ aj( i ≠ j )

For sequence a and sequence b, the integrating degree t is defined as follows(“⊕” denotes exclusive or):

t = (a0 ⊕ b0) + (a1 ⊕ b1) +···+ (an ⊕ bn)


(sequence B should also satisfy the rules described above)

Now give you a number n and the sequence a. You should calculate the maximum integrating degree t and print the sequence b.
 

Input
There are multiple test cases. Please process till EOF. 

For each case, the first line contains an integer n(1 ≤ n ≤ 105), The second line contains a0,a1,a2,...,an.
 

Output
For each case, output two lines.The first line contains the maximum integrating degree t. The second line contains n+1 integers b0,b1,b2,...,bn. There is exactly one space between bi and bi+1(0 ≤ i ≤ n - 1). Don’t ouput any spaces after bn.
 

Sample Input
4 2 0 1 4 3
 

Sample Output
20 1 0 2 3 4
 

Source

HDU 5014 Number Sequence(异或 进制问题)

标签:hdu   二进制   异或   

原文地址:http://blog.csdn.net/u012860063/article/details/39273917

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!