码迷,mamicode.com
首页 > 其他好文 > 详细

HDU - 5007 Post Robot

时间:2014-09-14 23:42:37      阅读:193      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   io   os   ar   strong   for   2014   


Problem Description
DT is a big fan of digital products. He writes posts about technological products almost everyday in his blog.

But there is such few comments of his posts that he feels depressed all the day. As his best friend and an excellent programmer, DT asked you to help make his blog look more popular. He is so warm that you have no idea how to refuse. But you are unwilling to read all of his boring posts word by word. So you decided to write a script to comment below his posts automatically.

After observation, you found words “Apple” appear everywhere in his posts. After your counting, you concluded that “Apple”, “iPhone”, “iPod”, “iPad” are the most high-frequency words in his blog. Once one of these words were read by your smart script, it will make a comment “MAI MAI MAI!”, and go on reading the post.

In order to make it more funny, you, as a fan of Sony, also want to make some comments about Sony. So you want to add a new rule to the script: make a comment “SONY DAFA IS GOOD!” when “Sony” appears.
 

Input
A blog article described above, which contains only printable characters(whose ASCII code is between 32 and 127), CR(ASCII code 13, ‘\r’ in C/C++), LF(ASCII code 10, ‘\n’ in C/C++), please process input until EOF. Note all characters are case sensitive.

The size of the article does not exceed 8KB.
 

Output
Output should contains comments generated by your script, one per line.
 

Sample Input
Apple bananaiPad lemon ApplepiSony 233 Tim cook is doubi from Apple iPhoneipad iPhone30 is so biiiiiiig Microsoft makes good App.
 

Sample Output
MAI MAI MAI! MAI MAI MAI! MAI MAI MAI! SONY DAFA IS GOOD! MAI MAI MAI! MAI MAI MAI! MAI MAI MAI!

思路:搜索就行了

#include <iostream>
#include <cstring>
#include <algorithm>
#include <cstdio>
using namespace std;

string arr[]={"Apple", "iPhone", "iPod", "iPad", "Sony"};

int main() {
	string str;
	while (cin >> str) {
		int len = str.length();
		for (int i = 0; i < len; i++) {
			if (len - i >= 4) {
				string four = str.substr(i, 4);
				if (four == "iPod" || four == "iPad")
					printf("MAI MAI MAI!\n");
				else if (four == "Sony")
					printf("SONY DAFA IS GOOD!\n");
			}
			if (len - i >= 5) {
				string five = str.substr(i, 5);
				if (five == "Apple")
					printf("MAI MAI MAI!\n");
			}
			if (len - i >= 6) {
				string six = str.substr(i, 6);
				if (six == "iPhone")
					printf("MAI MAI MAI!\n");
			}
		}	
	}
	return 0;
}


HDU - 5007 Post Robot

标签:des   style   blog   io   os   ar   strong   for   2014   

原文地址:http://blog.csdn.net/u011345136/article/details/39275737

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!