码迷,mamicode.com
首页 > 其他好文 > 详细

poj_2689_Prime Distance

时间:2017-11-23 08:41:09      阅读:153      评论:0      收藏:0      [点我收藏+]

标签:ogr   break   typedef   oss   because   memset   素数   while   fine   

The branch of mathematics called number theory is about properties of numbers. One of the areas that has captured the interest of number theoreticians for thousands of years is the question of primality. A prime number is a number that is has no proper factors (it is only evenly divisible by 1 and itself). The first prime numbers are 2,3,5,7 but they quickly become less frequent. One of the interesting questions is how dense they are in various ranges. Adjacent primes are two numbers that are both primes, but there are no other prime numbers between the adjacent primes. For example, 2,3 are the only adjacent primes that are also adjacent numbers.
Your program is given 2 numbers: L and U (1<=L< U<=2,147,483,647), and you are to find the two adjacent primes C1 and C2 (L<=C1< C2<=U) that are closest (i.e. C2-C1 is the minimum). If there are other pairs that are the same distance apart, use the first pair. You are also to find the two adjacent primes D1 and D2 (L<=D1< D2<=U) where D1 and D2 are as distant from each other as possible (again choosing the first pair if there is a tie).

Input

Each line of input will contain two positive integers, L and U, with L < U. The difference between L and U will not exceed 1,000,000.

Output

For each L and U, the output will either be the statement that there are no adjacent primes (because there are less than two primes between the two given numbers) or a line giving the two pairs of adjacent primes.

Sample Input

2 17
14 17

Sample Output

2,3 are closest, 7,11 are most distant.
There are no adjacent primes.


主要思想是偏移数组,区间素数打表。
#include<iostream>
#include<cstdio>
#include<cstring>
#include<queue>
typedef long long LL;
#include<algorithm>
using namespace std;
#define N 1000010
int notprime[N];
int prime[N];
int prime2[N];
bool vis[N];
bool val[N];
int pn=0;

void getPrime()
{
    memset(prime,0,sizeof(prime));
    for(int i=2;i<=N;i++)
    {
        if(!prime[i])prime[++prime[0]]=i;
        for(int j=1;j<=prime[0]&&prime[j]<=N/i;j++)
        {
            prime[prime[j]*i]=1;
            if(i%prime[j]==0)break;
        }
    }
}
void getPrime2(int L,int R)
{
    memset(notprime,false,sizeof(notprime));
    if(L<2)L=2;
    for(int i=1;i<=prime[0]&&(long long)prime[i]*prime[i]<=R;i++)
    {
        int s=L/prime[i]+(L%prime[i]>0);
        if(s==1)s=2;
        for(int j=s;(long long)j*prime[i]<=R;j++)
            if((long long)j*prime[i]>=L)
                notprime[j*prime[i]-L]=true;
    }
    prime2[0]=0;
    for(int i=0;i<=R-L;i++)
        if(!notprime[i])
            prime2[++prime2[0]]=i+L;
}

int main()
{
    getPrime();
    LL m,t,h;
    int l,r;
    while(~scanf("%d%d",&l,&r))
    {
        int sh1=0,sh2=1000000,lo1=0,lo2=0;
        getPrime2(l,r);
        if(prime2[0]<2)
        {
            puts("There are no adjacent primes.");
            continue;
        }
        for(int i=1;i<prime2[0];i++)
        {
            if(sh2-sh1>prime2[i+1]-prime2[i])
            {
                sh1=prime2[i];
                sh2=prime2[i+1];
            }
            if(lo2-lo1<prime2[i+1]-prime2[i])
            {
                lo1=prime2[i];
                lo2=prime2[i+1];
            }
        }
        printf("%d,%d are closest, %d,%d are most distant.\n",sh1,sh2,lo1,lo2);
    }
}

  

poj_2689_Prime Distance

标签:ogr   break   typedef   oss   because   memset   素数   while   fine   

原文地址:http://www.cnblogs.com/ygtzds/p/7881590.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!