码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1003 Max Sum(最大子列和)

时间:2014-09-16 22:15:51      阅读:248      评论:0      收藏:0      [点我收藏+]

标签:hdu   数学   子列   

题目链接:http://acm.hdu.edu.cn/showproblem.php?pid=1003


Problem Description
Given a sequence a[1],a[2],a[3]......a[n], your job is to calculate the max sum of a sub-sequence. For example, given (6,-1,5,4,-7), the max sum in this sequence is 6 + (-1) + 5 + 4 = 14.
 
Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line starts with a number N(1<=N<=100000), then N integers followed(all the integers are between -1000 and 1000).
 
Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line contains three integers, the Max Sum in the sequence, the start position of the sub-sequence, the end position of the sub-sequence. If there are more than one result, output the first one. Output a blank line between two cases.
 
Sample Input
2 5 6 -1 5 4 -7 7 0 6 -1 1 -6 7 -5
 
Sample Output
Case 1: 14 1 4 Case 2: 7 1 6


代码如下:

#include <cstdio>
#define INF 0x3f3f3f3f
int main()
{
    int t;
    int n, tt;
    scanf("%d",&t);
    int k = 0;
    while(t--)
    {
        scanf("%d",&n);
        int sum = 0, maxx = -INF;
        int start = 1, endd = 1, pos = 1;
        for(int i = 1; i <= n; i++)
        {
            scanf("%d",&tt);
            sum+=tt;
            if(sum > maxx)
            {
                start = pos;
                endd = i;
                maxx = sum;
            }
            if(sum < 0)
            {
                sum = 0;
                pos = i+1;
            }
        }
        printf("Case %d:\n",++k);
        printf("%d %d %d\n",maxx,start,endd);
        if(t)
            printf("\n");
    }
    return 0;
}




HDU 1003 Max Sum(最大子列和)

标签:hdu   数学   子列   

原文地址:http://blog.csdn.net/u012860063/article/details/39322883

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!