码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1044. Shopping in Mars

时间:2018-01-18 22:07:00      阅读:162      评论:0      收藏:0      [点我收藏+]

标签:code   number   inpu   return   payment   which   必须   cat   nan   

Shopping in Mars is quite a different experience. The Mars people pay by chained diamonds. Each diamond has a value (in Mars dollars M$). When making the payment, the chain can be cut at any position for only once and some of the diamonds are taken off the chain one by one. Once a diamond is off the chain, it cannot be taken back. For example, if we have a chain of 8 diamonds with values M$3, 2, 1, 5, 4, 6, 8, 7, and we must pay M$15. We may have 3 options:

  1. Cut the chain between 4 and 6, and take off the diamonds from the position 1 to 5 (with values 3+2+1+5+4=15).
  2. Cut before 5 or after 6, and take off the diamonds from the position 4 to 6 (with values 5+4+6=15).
  3. Cut before 8, and take off the diamonds from the position 7 to 8 (with values 8+7=15).

Now given the chain of diamond values and the amount that a customer has to pay, you are supposed to list all the paying options for the customer.

If it is impossible to pay the exact amount, you must suggest solutions with minimum lost.

Input Specification:

Each input file contains one test case. For each case, the first line contains 2 numbers: N (<=105), the total number of diamonds on the chain, and M (<=108), the amount that the customer has to pay. Then the next line contains N positive numbers D1 ... DN (Di<=103 for all i=1, ..., N) which are the values of the diamonds. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print "i-j" in a line for each pair of i <= j such that Di + ... + Dj = M. Note that if there are more than one solution, all the solutions must be printed in increasing order of i.

If there is no solution, output "i-j" for pairs of i <= j such that Di + ... + Dj > M with (Di + ... + Dj - M) minimized. Again all the solutions must be printed in increasing order of i.

It is guaranteed that the total value of diamonds is sufficient to pay the given amount.

Sample Input 1:

16 15
3 2 1 5 4 6 8 7 16 10 15 11 9 12 14 13

Sample Output 1:

1-5
4-6
7-8
11-11

Sample Input 2:

5 13
2 4 5 7 9

Sample Output 2:

2-4
4-5

分析
这道题我自己本来写了一个代码但最后一个点老是过不了,找了好久都找不到,于是上网搜了搜,大家都是用二分法,不知道为什么大家那么厉害都想到了这个巧妙的方法;
下面是转载的分析:

题目大意,求一串的数字中连续的一段,使得这个连续的段内数字的和恰好等于所期望的值m。如果不能找到恰好等于,就找让自己付出最少的价格(总和必须大于等于所给值)的那段区间。求所有可能的结果。
分析:一开始用的简单模拟,有两个超时了。后来想到因为sum数组是递增的,所以改用二分法查找~Func函数的作用是二分查找,修改tempsum和j的值~一开始接收输入的时候可以直接保存它的sum函数,即sum[i]表示1~i的所有数字的总和~

代码如下

#include<iostream>
#include<vector>
using namespace std;
int n,m,j,tempsum;
vector<int> vi,result; 
void findbestsum(int i){
    int left=i, right=n;
    while(left<right){
        int mid=(left+right)/2;
        if(vi[mid]-vi[i-1]>=m)
           right=mid;
        else 
           left=mid+1;
    }
    j=right;
    tempsum=vi[j]-vi[i-1];
}
int main(){
    cin>>n>>m;
    vi.resize(n+1,0);
    for(int i=1;i<=n;i++){
        cin>>vi[i];
        vi[i]+=vi[i-1];
    }
    int minans=vi[n];
    for(int i=1;i<=n;i++){
        findbestsum(i);
        if(tempsum>minans) continue;
        if(tempsum>=m){
            if(tempsum<minans){
                result.clear();
                minans=tempsum;
            }
            result.push_back(i);
            result.push_back(j);
        }
    }
    for(int i=0;i<result.size();i+=2)
        printf("%d-%d\n",result[i],result[i+1]);
    return 0;
}

PAT 1044. Shopping in Mars

标签:code   number   inpu   return   payment   which   必须   cat   nan   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8313110.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!