码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1090. Highest Price in Supply Chain

时间:2018-02-04 18:11:02      阅读:172      评论:0      收藏:0      [点我收藏+]

标签:out   ==   ica   ecif   ace   member   body   sample   push   

A supply chain is a network of retailers(零售商), distributors(经销商), and suppliers(供应商)-- everyone involved in moving a product from supplier to customer.

Starting from one root supplier, everyone on the chain buys products from one‘s supplier in a price P and sell or distribute them in a price that is r% higher than P. It is assumed that each member in the supply chain has exactly one supplier except the root supplier, and there is no supply cycle.

Now given a supply chain, you are supposed to tell the highest price we can expect from some retailers.

Input Specification:

Each input file contains one test case. For each case, The first line contains three positive numbers: N (<=105), the total number of the members in the supply chain (and hence they are numbered from 0 to N-1); P, the price given by the root supplier; and r, the percentage rate of price increment for each distributor or retailer. Then the next line contains N numbers, each number Si is the index of the supplier for the i-th member. Sroot for the root supplier is defined to be -1. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the highest price we can expect from some retailers, accurate up to 2 decimal places, and the number of retailers that sell at the highest price. There must be one space between the two numbers. It is guaranteed that the price will not exceed 1010.

Sample Input:

9 1.80 1.00
1 5 4 4 -1 4 5 3 6

Sample Output:

1.85 2

分析

用邻接表法建树,dfs遍历,不难

#include<iostream>
#include<vector>
#include<math.h>
using namespace std;
int cnt=0,level=0,visited[100005]={0};
double p,r,maxprice=-1;
vector<int> G[100005];
void dfs(int s){
     level++;
     if(G[s].size()==0){
        if(p*pow(1+0.01*r,level-1)>maxprice){
            cnt=1;
            maxprice=p*pow(1+0.01*r,level-1);
        }else if(p*pow(1+0.01*r,level-1)==maxprice)
            cnt++; 
     }
     for(int i=0;i<G[s].size();i++)
            dfs(G[s][i]);
     level--;
} 
int main(){
    int n,t,s;
    cin>>n>>p>>r;
    for(int i=0;i<n;i++){
        cin>>t;
        if(t==-1) s=i;
        else G[t].push_back(i); 
    }   
    dfs(s);
    printf("%.2lf %d",maxprice,cnt);
    return 0;
} 

PAT 1090. Highest Price in Supply Chain

标签:out   ==   ica   ecif   ace   member   body   sample   push   

原文地址:https://www.cnblogs.com/A-Little-Nut/p/8413519.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!