码迷,mamicode.com
首页 > 其他好文 > 详细

PAT 1052. Linked List Sorting (25)

时间:2018-02-12 00:20:11      阅读:228      评论:0      收藏:0      [点我收藏+]

标签:对比   地址   tar   ret   inpu   head   using   []   turn   

1052. Linked List Sorting (25)

时间限制
400 ms
内存限制
65536 kB
代码长度限制
16000 B
判题程序
Standard
作者
CHEN, Yue

A linked list consists of a series of structures, which are not necessarily adjacent in memory. We assume that each structure contains an integer key and a Next pointer to the next structure. Now given a linked list, you are supposed to sort the structures according to their key values in increasing order.

Input Specification:

Each input file contains one test case. For each case, the first line contains a positive N (< 105) and an address of the head node, where N is the total number of nodes in memory and the address of a node is a 5-digit positive integer. NULL is represented by -1.

Then N lines follow, each describes a node in the format:

Address Key Next

where Address is the address of the node in memory, Key is an integer in [-105, 105], and Next is the address of the next node. It is guaranteed that all the keys are distinct and there is no cycle in the linked list starting from the head node.

Output Specification:

For each test case, the output format is the same as that of the input, where N is the total number of nodes in the list and all the nodes must be sorted order.

Sample Input:
5 00001
11111 100 -1
00001 0 22222
33333 100000 11111
12345 -1 33333
22222 1000 12345
Sample Output:
5 12345
12345 -1 00001
00001 0 11111
11111 100 22222
22222 1000 33333
33333 100000 -1

 

需要判断是否为空链,即判断初试地址是否为-1。

地址没有必要用string和char[],使用string会超时,使用char[]时无法使用map,完全可以使用int,输出时用%05d。

 

#include <bits/stdc++.h>

using namespace std;

int N;
int s;
struct Node {
    int address;
    int next;
    int key;
    bool operator < (const Node &n) const {
        return key < n.key;
    }
}nodes[100005], nodesAns[100005];
map<int, int> nextMap;
map<int, Node> nodeMap;

int main()
{
    cin>>N;
    cin>>s;
    for(int i = 0; i < N; i++) {
        scanf("%d%d%d", &nodes[i].address, &nodes[i].key, &nodes[i].next);
        nextMap[nodes[i].address] = nodes[i].next;
        nodeMap[nodes[i].address] = nodes[i];
    }
    if(s == -1) {
        printf("0 -1");
        return 0;
    }
    int index = 0;
    while(1) {
        if(s == -1) break;
        nodesAns[index] = nodeMap[s];
        index++;
        s = nextMap[s];
    }
    sort(nodesAns, nodesAns+index);
    //cout<< index<< " "<< nodesAns[0].address<< endl;
    printf("%d %05d\n", index, nodesAns[0].address);
    for(int i = 0; i < index; i++) {
        if(i != index-1) printf("%05d %d %05d\n", nodesAns[i].address, nodesAns[i].key, nodesAns[i+1].address);
        else {
            printf("%05d %d -1", nodesAns[i].address, nodesAns[i].key);
        }
    }
    return 0;
}

 

PAT 1052. Linked List Sorting (25)

标签:对比   地址   tar   ret   inpu   head   using   []   turn   

原文地址:https://www.cnblogs.com/ACMessi/p/8443467.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!