码迷,mamicode.com
首页 > 其他好文 > 详细

POJ3041 Asteroids(二分图最小点覆盖)

时间:2018-02-12 00:24:57      阅读:210      评论:0      收藏:0      [点我收藏+]

标签:algorithm   present   back   div   iostream   nbsp   ati   bsp   wan   

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 


OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).
 
题意:有一个n*n的方格,方格上有m个点,每次可以消去一行或一列的所有点,请问至少需要几次才能消去所有点?
题解:一开始真没想到是二分图,后面想想一个点要么是从x坐标被消去,要么是从y坐标
把x坐标和y坐标分成两边,一个点则是一条边,那么问题就变成了如何用最少的点连接所有的边?
这是很典型的最小点覆盖问题
在二分图中最小点覆盖=最大匹配数
然后跑一边匈牙利就可以了
代码如下:
#include<vector>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;

vector<int> g[10010];
int vis[10010],link[10010];
int n,m;

bool check(int x)
{
    int sz=g[x].size();
    for(int i=0;i<sz;i++)
    {
        int y=g[x][i];
        if(!vis[y])
        {
            vis[y]=1;
            if(!link[y]||check(link[y]))
            {
                link[y]=x;
                return 1;
            }
        }
    }
    return 0;
}

int search()
{
    int ans=0;
    for(int i=1;i<=n;i++)
    {
        memset(vis,0,sizeof(vis));
        if(check(i))
        {
            ans++;
        }
    }
    return ans;
}

int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=m;i++)
    {
        int f,t;
        scanf("%d%d",&f,&t);
        g[f].push_back(t);
    }
    int cnt=search();
    printf("%d\n",cnt);
 } 

 

 
 
 
 
 
 

POJ3041 Asteroids(二分图最小点覆盖)

标签:algorithm   present   back   div   iostream   nbsp   ati   bsp   wan   

原文地址:https://www.cnblogs.com/stxy-ferryman/p/8443452.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!