码迷,mamicode.com
首页 > 其他好文 > 详细

poj 2485 Prim裸

时间:2018-03-09 20:27:41      阅读:181      评论:0      收藏:0      [点我收藏+]

标签:als   poj   ios   iss   最小   turn   input   tput   direct   

Highways
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 34492   Accepted: 15570

Description

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has no public highways. So the traffic is difficult in Flatopia. The Flatopian government is aware of this problem. They‘re planning to build some highways so that it will be possible to drive between any pair of towns without leaving the highway system.

Flatopian towns are numbered from 1 to N. Each highway connects exactly two towns. All highways follow straight lines. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways.

The Flatopian government wants to minimize the length of the longest highway to be built. However, they want to guarantee that every town is highway-reachable from every other town.

Input

The first line of input is an integer T, which tells how many test cases followed.
The first line of each case is an integer N (3 <= N <= 500), which is the number of villages. Then come N lines, the i-th of which contains N integers, and the j-th of these N integers is the distance (the distance should be an integer within [1, 65536]) between village i and village j. There is an empty line after each test case.

Output

For each test case, you should output a line contains an integer, which is the length of the longest road to be built such that all the villages are connected, and this value is minimum.

Sample Input

1

3
0 990 692
990 0 179
692 179 0

Sample Output

692


此题为最小生成树入门题,裸prim水过就可以了,求最短路径的最长线段

#include<iostream>
#include<cstring>
using namespace std;

const int INF = 0x3f3f3f;
const int MAXN = 500;
int map[MAXN+1][MAXN+1];
int dis[MAXN+1];
bool visited[MAXN+1];
 
int prim(int n)
{
    int visit,max_line = -INF,min_path;
    memset(visited,false,sizeof(visited));
    visited[0] = true;
    for(int i = 0;i<n;i++)
        dis[i] = map[0][i];
    for(int j = 1;j<n;j++)
    {
        min_path = INF;
        for(int i = 0;i<n;i++)
        {    
            if(visited[i] == false && min_path > dis[i])    
            {
                visit = i;
                min_path = dis[i];
            }
        }
        //cout<<min_path<<endl;
        if(max_line < min_path)
            max_line = min_path;
        visited[visit] = true;
        for(int i = 0;i<n;i++)
            if(visited[i] == false && dis[i] > map[visit][i])
                dis[i] = map[visit][i];
    }    
    return max_line;    
}

int main()
{
    int count,n;
    cin>>count;
    while(count--)
    {
        cin>>n;
        for(int i = 0;i<n;i++)
            for(int j = 0;j<n;j++)
                cin>>map[i][j];
        cout<<prim(n)<<endl;
    }
    return 0;
} 

 

poj 2485 Prim裸

标签:als   poj   ios   iss   最小   turn   input   tput   direct   

原文地址:https://www.cnblogs.com/ZZUGPY/p/8535455.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!