码迷,mamicode.com
首页 > 数据库 > 详细

hdu1397(Goldbach`s Conjecture )

时间:2018-03-15 21:09:17      阅读:205      评论:0      收藏:0      [点我收藏+]

标签:closed   ble   line   ane   may   des   fuse   one   refused   

Goldbach‘s Conjecture

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 7550    Accepted Submission(s): 2877


Problem Description
Goldbach‘s Conjecture: For any even number n greater than or equal to 4, there exists at least one pair of prime numbers p1 and p2 such that n = p1 + p2.
This conjecture has not been proved nor refused yet. No one is sure whether this conjecture actually holds. However, one can find such a pair of prime numbers, if any, for a given even number. The problem here is to write a program that reports the number of all the pairs of prime numbers satisfying the condition in the conjecture for a given even number.

A sequence of even numbers is given as input. Corresponding to each number, the program should output the number of pairs mentioned above. Notice that we are interested in the number of essentially different pairs and therefore you should not count (p1, p2) and (p2, p1) separately as two different pairs.
 
Input
An integer is given in each input line. You may assume that each integer is even, and is greater than or equal to 4 and less than 2^15. The end of the input is indicated by a number 0.
 
Output
Each output line should contain an integer number. No other characters should appear in the output.
 
Sample Input
6 10 12 0
Sample Output
1 2 1
 
分析:用筛法求素数并用数组s记录下来就好了。
技术分享图片
#include<cstdio>
bool a[10000010];
int s[1000000];
int cnt=0;
void prime()
{
    for(int i=4;i<10000001;i+=2) a[i]=1;
    s[cnt++]=2;
    for(int i=3;i<10000001;i++)
    {
        if(!a[i])
        {
            s[cnt++]=i;
            for(int j=i+i;j<10000001;j+=i)
            a[j]=1;
        }
    } 
}

int main()
{
    int n;
    prime();
    while(scanf("%d",&n)&&n)
    {
        int N=n/2,ans=0;
        int i=0;
        while(s[i]<=N)
        {
            if(!a[n-s[i]]) ans++;
            i++;
        }
        printf("%d\n",ans);
    }
    return 0;
}
View Code

 

 

hdu1397(Goldbach`s Conjecture )

标签:closed   ble   line   ane   may   des   fuse   one   refused   

原文地址:https://www.cnblogs.com/ACRykl/p/8576041.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!