码迷,mamicode.com
首页 > 其他好文 > 详细

洛谷 P2888 [USACO07NOV]牛栏Cow Hurdles

时间:2018-03-17 12:22:42      阅读:174      评论:0      收藏:0      [点我收藏+]

标签:min   pair   usaco   put   ref   room   practice   cst   ted   

                    洛谷 P2888 [USACO07NOV]牛栏Cow Hurdles

题目描述

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows‘ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.

  Farmer John 想让她的奶牛准备郡级跳跃比赛,贝茜和她的伙伴们正在练习跨栏。她们很累,所以她们想消耗最少的能量来跨栏。 显然,对于一头奶牛跳过几个矮栏是很容易的,但是高栏却很难。于是,奶牛们总是关心路径上最高的栏的高度。 奶牛的训练场中有 N (1 ≤ N ≤ 300) 个站台,分别标记为1..N。所有站台之间有M (1 ≤ M ≤ 25,000)条单向路径,第i条路经是从站台Si开始,到站台Ei,其中最高的栏的高度为Hi (1 ≤ Hi ≤ 1,000,000)。无论如何跑,奶牛们都要跨栏。 奶牛们有 T (1 ≤ T ≤ 40,000) 个训练任务要完成。第 i 个任务包含两个数字 Ai 和 Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N),表示奶牛必须从站台Ai跑到站台Bi,可以路过别的站台。奶牛们想找一条路径从站台Ai到站台Bi,使路径上最高的栏的高度最小。 你的任务就是写一个程序,计算出路径上最高的栏的高度的最小值。

输入输出格式

输入格式:

 

* Line 1: Three space-separated integers: N, M, and T

* Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi

* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

行 1: 两个整数 N, M, T

行 2..M+1: 行 i+1 包含三个整数 Si , Ei , Hi

行 M+2..M+T+1: 行 i+M+1 包含两个整数,表示任务i的起始站台和目标站台: Ai , Bi

 

输出格式:

 

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

行 1..T: 行 i 为一个整数,表示任务i路径上最高的栏的高度的最小值。如果无法到达,输出 -1。

 

输入输出样例

输入样例#1: 复制
5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1
输出样例#1: 复制
4
8
-1

考察算法:Floyd 难度:普及/提高-
思路:几乎是Floyd板子题,只需要把三重循环里的判断条件略微修改即可
#include<algorithm>
#include<iostream>
#include<cstring>
#include<cstdio>
#include<cmath>
#define MAXN 999999
using namespace std;
int n, m, t;
int si, ei, hi, ai[40001], bi[40001];
int dis[301][301];
int main() {
    scanf("%d%d%d", &n, &m, &t);
    for(int i = 1; i <= n; i++)
        for(int j = 1; j <= n; j++)
            dis[i][j] = MAXN;          //初始化
    for(int i = 1; i <= m; i++) {
        scanf("%d%d%d", &si, &ei, &hi);
        dis[si][ei] = hi;       //建边
    }
    for(int i = 1; i <= t; i++)
        scanf("%d%d", &ai[i], &bi[i]);
    for(int k = 1; k <= n; k++)
        for(int i = 1; i <= n; i++)
            for(int j = 1; j <= n; j++)
                if(dis[i][j] > max(dis[i][k], dis[k][j]))    //修改判断条件,求出最高栏的值 
                    dis[i][j] = max(dis[i][k], dis[k][j]);
    for(int i = 1; i <= t; i++) {
        if(dis[ai[i]][bi[i]] != MAXN)
            printf("%d\n", dis[ai[i]][bi[i]]);
        else printf("-1\n");
    }
    return 0;
}

洛谷 P2888 [USACO07NOV]牛栏Cow Hurdles

标签:min   pair   usaco   put   ref   room   practice   cst   ted   

原文地址:https://www.cnblogs.com/v-vip/p/8587806.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!