码迷,mamicode.com
首页 > 其他好文 > 详细

BZOJ3282: Tree

时间:2018-03-21 21:10:16      阅读:204      评论:0      收藏:0      [点我收藏+]

标签:algo   表连接   body   make   bsp   href   cstring   存在   main   

Description

给定N个点以及每个点的权值,要你处理接下来的M个操作。
操作有4种。操作从0到3编号。点从1到N编号。
0:后接两个整数(x,y),代表询问从x到y的路径上的点的权值的xor和。
保证x到y是联通的。
1:后接两个整数(x,y),代表连接x到y,若x到Y已经联通则无需连接。
2:后接两个整数(x,y),代表删除边(x,y),不保证边(x,y)存在。
3:后接两个整数(x,y),代表将点X上的权值变成Y。

Input

第1行两个整数,分别为N和M,代表点数和操作数。
第2行到第N+1行,每行一个整数,整数在[1,10^9]内,代表每个点的权值。
第N+2行到第N+M+1行,每行三个整数,分别代表操作类型和操作所需的量。
1<=N,M<=300000

Output

对于每一个0号操作,你须输出X到Y的路径上点权的Xor和。

Sample Input

3 3
1
2
3
1 1 2
0 1 2
0 1 1

Sample Output

3
1
 
 
人生第一道认真做+认真想的LCT???
其实我还有很多不懂的地方。。。但这是模板题我就不讲了
怎么感觉Link_cut_tree码量很少。。。
 
代码如下:
#include<cmath>
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<algorithm>
using namespace std;
struct Link_cut_tree{
    int f,son[2],c,sum;
    bool fz;
    Link_cut_tree(){c=sum=0;fz=false;}
}tr[310000];int n,m;
void reverse(int x)
{
    tr[x].fz=false;
    int lc=tr[x].son[0],rc=tr[x].son[1];
    swap(tr[x].son[0],tr[x].son[1]);
    tr[lc].fz^=1;
    tr[rc].fz^=1;    
} 
void update(int x)
{
    int lc=tr[x].son[0],rc=tr[x].son[1];
    tr[x].sum=tr[lc].sum^tr[rc].sum^tr[x].c;
}
void rotate(int x,int w)
{
    int r,R;
    int f=tr[x].f,ff=tr[f].f;
    
    r=tr[x].son[w],R=f;
    tr[R].son[1-w]=r;
    if(r!=0)tr[r].f=R;
    
    r=x,R=ff;
    if(tr[R].son[0]==f)tr[R].son[0]=r;
    else if(tr[R].son[1]==f)tr[R].son[1]=r;
    tr[r].f=R;
    
    r=f,R=x;
    tr[R].son[w]=r;
    tr[r].f=R;
    
    update(f);
    update(x);
}
int tmp[310000];
void splay(int x,int rt)
{
    int i=x,s=0;
    while(tr[i].f!=rt&&(tr[tr[i].f].son[0]==i||tr[tr[i].f].son[1]==i))
    {
        tmp[++s]=i;
        i=tr[i].f;
    }
    tmp[++s]=i;
    while(s>0)
    {
        i=tmp[s--];
        if(tr[i].fz==true)reverse(i);
    }
    while(tr[x].f!=rt&&(tr[tr[x].f].son[0]==x||tr[tr[x].f].son[1]==x))
    {
        int f=tr[x].f,ff=tr[f].f;
        if(ff==rt||(tr[ff].son[0]!=f&&tr[ff].son[1]!=f))
        {
            if(tr[f].son[0]==x)rotate(x,1);
            else rotate(x,0);
        }
        else
        {
                 if(tr[ff].son[0]==f&&tr[f].son[0]==x)rotate(f,1),rotate(x,1);
            else if(tr[ff].son[0]==f&&tr[f].son[1]==x)rotate(x,0),rotate(x,1);
            else if(tr[ff].son[1]==f&&tr[f].son[0]==x)rotate(x,1),rotate(x,0);
            else if(tr[ff].son[1]==f&&tr[f].son[1]==x)rotate(f,0),rotate(x,0);
        }
    }
}
void access(int x)
{
    int y=0;
    while(x!=0)
    {
        splay(x,0);
        tr[x].son[1]=y;
        if(y!=0)tr[y].f=x;
        y=x,x=tr[x].f;
    }
}
void makeroot(int x)
{
    access(x);splay(x,0);
    tr[x].fz^=1;
}
void Link(int x,int y)
{
    makeroot(x),tr[x].f=y;
    access(x);
}
int findroot(int x)
{
    access(x),splay(x,0);
    while(tr[x].son[0]!=0)x=tr[x].son[0];
    return x;
}
void Cut(int x,int y)
{
    if(findroot(x)!=findroot(y))return ;
    makeroot(x),access(y);
    splay(y,0);
    tr[tr[y].son[0]].f=0;tr[y].son[0]=0;
}
int findsum(int x,int y)
{
    makeroot(x),access(y),splay(y,0);
    return tr[tr[y].son[0]].sum^tr[y].c;
}
int main()
{
    scanf("%d%d",&n,&m);
    for(int i=1;i<=n;i++){scanf("%d",&tr[i].c);tr[i].sum=tr[i].c;}
    while(m--)
    {
        int op,x,y;
        scanf("%d%d%d",&op,&x,&y);
        if(op==0)printf("%d\n",findsum(x,y));
        else if(op==1)
        {
            int tmpx=findroot(x);
            int tmpy=findroot(y);
            if(tmpx!=tmpy)Link(x,y);
        }
        else if(op==2)Cut(x,y);
        else
        {
            makeroot(x);
            tr[x].c=y;update(x);
        }
    }
    return 0;
}

by_lmy

BZOJ3282: Tree

标签:algo   表连接   body   make   bsp   href   cstring   存在   main   

原文地址:https://www.cnblogs.com/MT-LI/p/8619194.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!