码迷,mamicode.com
首页 > 其他好文 > 详细

1075. PAT Judge (25)

时间:2018-03-23 11:44:13      阅读:163      评论:0      收藏:0      [点我收藏+]

标签:OWIN   ant   inpu   tee   struct   rate   ...   compiler   cannot   

The ranklist of PAT is generated from the status list, which shows the scores of the submittions. This time you are supposed to generate the ranklist for PAT.

Input Specification:

Each input file contains one test case. For each case, the first line contains 3 positive integers, N (<=104), the total number of users, K (<=5), the total number of problems, and M (<=105), the total number of submittions. It is then assumed that the user id‘s are 5-digit numbers from 00001 to N, and the problem id‘s are from 1 to K. The next line contains K positive integers p[i] (i=1, ..., K), where p[i] corresponds to the full mark of the i-th problem. Then M lines follow, each gives the information of a submittion in the following format:

user_id problem_id partial_score_obtained

where partial_score_obtained is either -1 if the submittion cannot even pass the compiler, or is an integer in the range [0, p[problem_id]]. All the numbers in a line are separated by a space.

Output Specification:

For each test case, you are supposed to output the ranklist in the following format:

rank user_id total_score s[1] ... s[K]

where rank is calculated according to the total_score, and all the users with the same total_score obtain the same rank; and s[i] is the partial score obtained for the i-th problem. If a user has never submitted a solution for a problem, then "-" must be printed at the corresponding position. If a user has submitted several solutions to solve one problem, then the highest score will be counted.

The ranklist must be printed in non-decreasing order of the ranks. For those who have the same rank, users must be sorted in nonincreasing order according to the number of perfectly solved problems. And if there is still a tie, then they must be printed in increasing order of their id‘s. For those who has never submitted any solution that can pass the compiler, or has never submitted any solution, they must NOT be shown on the ranklist. It is guaranteed that at least one user can be shown on the ranklist.

Sample Input:

7 4 20
20 25 25 30
00002 2 12
00007 4 17
00005 1 19
00007 2 25
00005 1 20
00002 2 2
00005 1 15
00001 1 18
00004 3 25
00002 2 25
00005 3 22
00006 4 -1
00001 2 18
00002 1 20
00004 1 15
00002 4 18
00001 3 4
00001 4 2
00005 2 -1
00004 2 0

Sample Output:

1 00002 63 20 25 - 18
2 00005 42 20 0 22 -
2 00007 42 - 25 - 17
2 00001 42 18 18 4 2
5 00004 40 15 0 25 -
#include<cstdio>
#include<algorithm>

using namespace std;
const int maxn = 100010;
struct User{
    int id;
    int grade[6]; //题的得分 
    int total;
    int perfect;
    bool flag;
}user[maxn];

int full[6] = {0}; //记录每道题满分值 
int n,k,m;//用户数,题目数,提交数   n的声明要在全局处 

bool cmp(User a,User b){
    if(a.flag != b.flag) return a.flag > b.flag;
    else if(a.total != b.total) return a.total > b.total;
    else if(a.perfect != b.perfect) return a.perfect > b.perfect;
    else return a.id< b.id;        //id的类型是int 
}

void init(){
    for(int i = 1; i <= n; i++){    //编号是从 1 开始,等号就要取到 
        user[i].id = i;
        user[i].total = 0;
        user[i].perfect = 0;
        memset(user[i].grade,-1,sizeof(user[i].grade));  //
        user[i].flag = false;
    }
}
int main(){
    
    scanf("%d%d%d",&n,&k,&m);
    for(int i = 1; i <= k; i++){
        scanf("%d",&full[i]);
    } 
    init();
    int u_id,p_id,get_score;
    for(int i = 0; i < m; i++){
        scanf("%d%d%d",&u_id,&p_id,&get_score);
        if(get_score != -1){
            user[u_id].flag = true;
        }
        if(get_score == -1 && user[u_id].grade[p_id] == -1){  
            user[u_id].grade[p_id] = 0;
        }
        if(get_score == full[p_id] && user[u_id].grade[p_id] < full[p_id]){
            user[u_id].perfect++;    //第一次获得满分 
        }
        if(get_score > user[u_id].grade[p_id]){
            user[u_id].grade[p_id] = get_score;
        }
    }
    for(int i = 1; i <= n; i++){
        for(int j = 1; j <= k; j++){   //k是题目数 
            if(user[i].grade[j] != -1){
                user[i].total += user[i].grade[j]; 
            }
        }
    }
    sort(user+1,user+n+1,cmp);
    int r = 1;
    for(int i = 1; i <= n && user[i].flag == true; i++){
        if(i >1 && user[i].total != user[i - 1].total){
            r = i;
        }
        printf("%d %05d %d",r,user[i].id,user[i].total);
        for(int j = 1; j <= k; j++){           //同上 
            if(user[i].grade[j] == -1){
                printf(" -");                
            }else{
              printf(" %d",user[i].grade[j]);
            }
        }
        printf("\n");
    }
    return 0;
} 

 

1075. PAT Judge (25)

标签:OWIN   ant   inpu   tee   struct   rate   ...   compiler   cannot   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8628761.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!