码迷,mamicode.com
首页 > 其他好文 > 详细

hdu 1040

时间:2018-04-13 14:30:42      阅读:145      评论:0      收藏:0      [点我收藏+]

标签:else   res   tin   think   pid   multiple   author   ref   blank   

As Easy As A+B

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 70286    Accepted Submission(s): 29895


Problem Description
These days, I am thinking about a question, how can I get a problem as easy as A+B? It is fairly difficulty to do such a thing. Of course, I got it after many waking nights.
Give you some integers, your task is to sort these number ascending (升序).
You should know how easy the problem is now!
Good luck!
 
Input
Input contains multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains an integer N (1<=N<=1000 the number of integers to be sorted) and then N integers follow in the same line. 
It is guarantied that all integers are in the range of 32-int.
 
Output
For each case, print the sorting result, and one line one case.
 
Sample Input
2 3 2 1 3 9 1 4 7 2 5 8 3 6 9
 
Sample Output
1 2 3 1 2 3 4 5 6 7 8 9
 
Author
lcy
思路:手写快排,
#include<cstdio>
#include<set>
#include<iostream>
#include<functional>
#include<algorithm>
using namespace std;
void quick_sort(int a[], int low, int high)
{
    if (low >= high)return;
    int s = low, e = high, key = a[low];
    while (s < e){
        while (s < e && a[e] >= key)e--;
        a[s] = a[e];
        while (s < e && a[s] <= key)s++;
        a[e] = a[s];
    }
    a[s] = key;
    quick_sort(a, low, s - 1);
    quick_sort(a, s + 1, high);
}
int main()
{
    int a[1006];
    int t; cin >> t;
    while (t--) {
        int n; cin >> n;

        for (int i = 0; i < n; i++)
            cin >> a[i];
        quick_sort(a, 0, n - 1);
        for (int i = 0; i < n; i++){
            if (i == n - 1)cout << a[i] << endl;
            else cout << a[i] << " ";
        }

    }
    return 0;
}

 

 

hdu 1040

标签:else   res   tin   think   pid   multiple   author   ref   blank   

原文地址:https://www.cnblogs.com/zengguoqiang/p/8819891.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!