码迷,mamicode.com
首页 > 其他好文 > 详细

hdu5024Wang Xifeng's Little Plot(思维|搜索)

时间:2014-09-24 20:11:31      阅读:278      评论:0      收藏:0      [点我收藏+]

标签:des   style   blog   http   color   io   os   java   ar   

题目链接:

题意:

从图中任何一个点走,最多只能转90度的弯,并且只能转一次弯,求这个最长路。。
思路:
ym的朝鲜选手的代码,真厉害啊,它是每个点的8个方向都走一遍,然后最后遍历全图,去每个点最多转一次弯的最大长度,这个确实有点厉害,相当于枚举拐点。。还有就是方向最好的按顺序来,因为一个直角正好隔两个方向的位,好运算。。
题目

Wang Xifeng‘s Little Plot

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 362    Accepted Submission(s): 243


Problem Description
《Dream of the Red Chamber》(also 《The Story of the Stone》) is one of the Four Great Classical Novels of Chinese literature, and it is commonly regarded as the best one. This novel was created in Qing Dynasty, by Cao Xueqin. But the last 40 chapters of the original version is missing, and that part of current version was written by Gao E. There is a heart breaking story saying that after Cao Xueqin died, Cao‘s wife burned the last 40 chapter manuscript for heating because she was desperately poor. This story was proved a rumor a couple of days ago because someone found several pages of the original last 40 chapters written by Cao. 

In the novel, Wang Xifeng was in charge of Da Guan Yuan, where people of Jia family lived. It was mentioned in the newly recovered pages that Wang Xifeng used to arrange rooms for Jia Baoyu, Lin Daiyu, Xue Baochai and other teenagers. Because Jia Baoyu was the most important inheritor of Jia family, and Xue Baochai was beautiful and very capable , Wang Xifeng didn‘t want Jia Baoyu to marry Xue Baochai, in case that Xue Baochai might take her place. So, Wang Xifeng wanted Baoyu‘s room and Baochai‘s room to be located at two ends of a road, and this road should be as long as possible. But Baoyu was very bad at directions, and he demanded that there could be at most one turn along the road from his room to Baochai‘s room, and if there was a turn, that turn must be ninety degree. There is a map of Da Guan Yuan in the novel, and redists (In China English, one whose job is studying 《Dream of the Red Chamber》is call a "redist") are always arguing about the location of Baoyu‘s room and Baochai‘s room. Now you can solve this big problem and then become a great redist.
 

Input
The map of Da Guan Yuan is represented by a matrix of characters ‘.‘ and ‘#‘. A ‘.‘ stands for a part of road, and a ‘#‘ stands for other things which one cannot step onto. When standing on a ‘.‘, one can go to adjacent ‘.‘s through 8 directions: north, north-west, west, south-west, south, south-east,east and north-east.

There are several test cases.

For each case, the first line is an integer N(0<N<=100) ,meaning the map is a N × N matrix.

Then the N × N matrix follows.

The input ends with N = 0.
 

Output
For each test case, print the maximum length of the road which Wang Xifeng could find to locate Baoyu and Baochai‘s rooms. A road‘s length is the number of ‘.‘s it includes. It‘s guaranteed that for any test case, the maximum length is at least 2.
 

Sample Input
3 #.# ##. ..# 3 ... ##. ..# 3 ... ### ..# 3 ... ##. ... 0
 

Sample Output
3 4 3 5
 

Source
 

Recommend
hujie   |   We have carefully selected several similar problems for you:  5041 5040 5039 5037 5036 
 
代码:
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<map>
#include<vector>
#include<cmath>
#include<string>
#include<queue>
#define eps 1e-9
#define ll long long
#define INF 0x3f3f3f3f
using namespace std;

const int maxn=100+10;
char mp[maxn][maxn];
int n;

int step[maxn][maxn][8];

int Dx[]={-1,-1,-1,0,1,1,1,0};
int Dy[]={-1,0,1,1,1,0,-1,-1};

bool is_in(int x,int y)
{
    if(x>=0&&x<n&&y>=0&&y<n&&mp[x][y]!='#')
        return true;
    return false;
}


int main()
{
   int dx,dy,ans;
   while(~scanf("%d",&n),n)
   {
       for(int i=0;i<n;i++)
         scanf("%s",mp[i]);
       memset(step,0,sizeof(step));
       for(int i=0;i<n;i++)
         for(int j=0;j<n;j++)
            for(int k=0;k<8;k++)
               if(is_in(i,j))
         {
             dx=i,dy=j;
             while(is_in(dx,dy))
             {
                 step[dx][dy][k]++;
                 dx+=Dx[k];
                 dy+=Dy[k];
             }
         }
         ans=-1;
         for(int i=0;i<n;i++)
            for(int j=0;j<n;j++)
              for(int k=0;k<8;k++)
                 if(is_in(i,j))
         {
             int xx=(k+2)%8;
             ans=max(ans,step[i][j][k]+step[i][j][xx]-1);
             int yy=(k+6)%8;
             ans=max(ans,step[i][j][k]+step[i][j][yy]-1);
         }
         printf("%d\n",ans);
   }
   return 0;
}


hdu5024Wang Xifeng's Little Plot(思维|搜索)

标签:des   style   blog   http   color   io   os   java   ar   

原文地址:http://blog.csdn.net/u014303647/article/details/39526151

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!