码迷,mamicode.com
首页 > 其他好文 > 详细

1096. Consecutive Factors (20)

时间:2018-04-18 21:20:58      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:seq   sed   included   ted   lis   for   contains   may   str   

Among all the factors of a positive integer N, there may exist several consecutive numbers. For example, 630 can be factored as 3*5*6*7, where 5, 6, and 7 are the three consecutive numbers. Now given any positive N, you are supposed to find the maximum number of consecutive factors, and list the smallest sequence of the consecutive factors.

Input Specification:

Each input file contains one test case, which gives the integer N (1<N<231).

Output Specification:

For each test case, print in the first line the maximum number of consecutive factors. Then in the second line, print the smallest sequence of the consecutive factors in the format "factor[1]*factor[2]*...*factor[k]", where the factors are listed in increasing order, and 1 is NOT included.

Sample Input:

630

Sample Output:

3
5*6*7
#include<cstdio>
#include<cmath>
typedef long long ll;
int main(){
    ll n;
    scanf("%lld",&n);
    ll sqr = (int)sqrt(1.0*n),ansI=0,ansLen = 0;
    for(ll i = 2; i <= sqr; i++){
        ll temp = 1,j = i;
        while(1){
            temp *= j;
            if(n % temp != 0) break;
            if(j - i + 1 > ansLen){
                ansI = i;
                ansLen = j - i + 1;
            }
            j++;
        }
    }
    if(ansLen == 0) printf("1\n%lld",n);
    else{
        printf("%lld\n",ansLen);
        for(ll i = 0; i < ansLen; i++){
            printf("%lld",ansI+i);
            if(i<ansLen - 1) printf("*");
        }
    }
    return 0;
}

 

1096. Consecutive Factors (20)

标签:seq   sed   included   ted   lis   for   contains   may   str   

原文地址:https://www.cnblogs.com/wanghao-boke/p/8877303.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!