码迷,mamicode.com
首页 > 其他好文 > 详细

Pat(Advanced Level)Practice--1018(Public Bike Management)

时间:2014-05-13 23:27:04      阅读:582      评论:0      收藏:0      [点我收藏+]

标签:advance pat   dijkstra   dfs   

Pat1018代码

题目描述:

There is a public bike service in Hangzhou City which provides great convenience to the tourists from all over the world. One may rent a bike at any station and return it to any other stations in the city.

The Public Bike Management Center (PBMC) keeps monitoring the real-time capacity of all the stations. A station is said to be in perfect condition if it is exactly half-full. If a station is full or empty, PBMC will collect or send bikes to adjust the condition of that station to perfect. And more, all the stations on the way will be adjusted as well.

When a problem station is reported, PBMC will always choose the shortest path to reach that station. If there are more than one shortest path, the one that requires the least number of bikes sent from PBMC will be chosen.

bubuko.com,布布扣
Figure 1

Figure 1 illustrates an example. The stations are represented by vertices and the roads correspond to the edges. The number on an edge is the time taken to reach one end station from another. The number written inside a vertex S is the current number of bikes stored at S. Given that the maximum capacity of each station is 10. To solve the problem at S3, we have 2 different shortest paths:

1. PBMC -> S1 -> S3. In this case, 4 bikes must be sent from PBMC, because we can collect 1 bike from S1 and then take 5 bikes to S3, so that both stations will be in perfect conditions.

2. PBMC -> S2 -> S3. This path requires the same time as path 1, but only 3 bikes sent from PBMC and hence is the one that will be chosen.

Input Specification:

Each input file contains one test case. For each case, the first line contains 4 numbers: Cmax (<= 100), always an even number, is the maximum capacity of each station; N (<= 500), the total number of stations; Sp, the index of the problem station (the stations are numbered from 1 to N, and PBMC is represented by the vertex 0); and M, the number of roads. The second line contains N non-negative numbers Ci(i=1,...N) where each Ci is the current number of bikes at Si respectively. Then M lines follow, each contains 3 numbers: Si, Sj, and Tij which describe the time Tij taken to move betwen stations Si and Sj. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print your results in one line. First output the number of bikes that PBMC must send. Then after one space, output the path in the format: 0->S1->...->Sp. Finally after another space, output the number of bikes that we must take back to PBMC after the condition of Sp is adjusted to perfect.

Note that if such a path is not unique, output the one that requires minimum number of bikes that we must take back to PBMC. The judge‘s data guarantee that such a path is unique.

Sample Input:
10 3 3 5
6 7 0
0 1 1
0 2 1
0 3 3
1 3 1
2 3 1
Sample Output:
3 0->2->3 0

AC代码:题目的意思是找路径最短的线路,如果相等则找带来自行车最少的线路,如果再相等则找带走自行车最少的线路;思路,Dijkstra+DFS,本来以为一遍Dijkstra就可以解决的,写到一半时发现,不到目的地根本没法选择路径;因为在选择最短路径的同时,还要使需要的自行车数目最少,以及剩余的自行车数目最少,用DSF就可以搞定;
#include<cstdio>
#include<stack>
#include<algorithm>
#define MAX 505
#define INF 0x0FFFFFFF

using namespace std;

int map[MAX][MAX];
int Station[MAX];
int visited[MAX],Length[MAX];
int FinalPath[MAX],TempPath[MAX];//Path 
int flag[MAX][MAX];//DFS flag
int c,n,s,m;
int takein=INF,takeout=INF;//takein to a station,takeout from a station
int finished;//finish flag
int shortdis;//the shortest distance from PBMC to station s
int nowstep,finalstep;

void Init(int n)
{
	int i,j;
	for(i=0;i<=n;i++)
	{
		Length[i]=INF;
		for(j=0;j<=n;j++)
			map[i][j]=INF;
	}
}

void Dijkstra(int n,int d)//计算最短路径
{
	int min=INF;
	int i,j,k;
	int num;
	for(i=0;i<=n;i++)
	{
		Length[i]=map[0][i];
		visited[i]=0;
	}
	Length[0]=0;
	visited[0]=1;
	for(i=1;i<=n;i++)
	{
		min=INF;
		for(j=0;j<=n;j++)
		{
			if(!visited[j]&&Length[j]<min)
			{
				min=Length[j];
				k=j;
			}
		}
		visited[k]=1;
		for(j=0;j<=n;j++)
		{
			if(!visited[j]&&Length[j]>min+map[k][j])
			{
				Length[j]=min+map[k][j];
			}
		}
	}
	shortdis=Length[d];
}

void Compute()//计算从PBMC到该站需要带来和带走多少辆自行车
{
	int in=INF,out=INF;
	int i;
	int sum=0;
	for(i=1;i<=nowstep;i++)
	{
		sum+=Station[TempPath[i]]-c/2;
		if(sum<in)//in表示的是从PBMC到该站的路径时要达到最佳状态需要带来
			in=sum;           //的自行车数目
	}
	if(in>0)//不需要带来自行车
		in=0;
	else
		in=-in;
	out=sum+in;//需要带出自行车
	if(in<takein||(in==takein&&out<takeout))
	{
		takein=in;
		takeout=out;
		if(takein==0&&takeout==0)
			finished=1;
		finalstep=nowstep;
		for(i=1;i<=nowstep;i++)//拷贝路径
			FinalPath[i]=TempPath[i];
	}
}

void DFS(int step,int start,int len)
{
	int j;
	if(finished==1||len>Length[start])
		return;
	if(len==shortdis&&start==s)
	{
		nowstep=step;
		Compute();
	}
	for(j=1;j<=n;j++)
	{
		if(flag[start][j]==1||map[j][start]==INF)
			continue;
		flag[start][j]=flag[j][start]=1;
		TempPath[step+1]=j;
		DFS(step+1,j,len+map[start][j]);
		flag[start][j]=flag[j][start]=0;
	}
}

void Display()
{
	int i;
	printf("%d 0",takein);
	for(i=1;i<=finalstep;i++)
		printf("->%d",FinalPath[i]);
	printf(" %d\n",takeout);
}

int main(int argc,char *argv[])
{
	int i;
	scanf("%d%d%d%d",&c,&n,&s,&m);
	Init(n);
	for(i=1;i<=n;i++)
		scanf("%d",&Station[i]);
	for(i=0;i<m;i++)
	{
		int x,y,len;
		scanf("%d%d%d",&x,&y,&len);
		map[x][y]=len;
		map[y][x]=len;
	}
	Dijkstra(n,s);
	DFS(0,0,0);
	Display();
	return 0;
}


Pat(Advanced Level)Practice--1018(Public Bike Management),布布扣,bubuko.com

Pat(Advanced Level)Practice--1018(Public Bike Management)

标签:advance pat   dijkstra   dfs   

原文地址:http://blog.csdn.net/cstopcoder/article/details/25569051

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!