码迷,mamicode.com
首页 > 编程语言 > 详细

idea 2017.3创建springboot项目报无效的源发行版: 1.8或者Unsupported major.minor version 52.0的解决方案

时间:2018-05-03 00:59:34      阅读:8385      评论:0      收藏:0      [点我收藏+]

标签:com   图片   1.7   info   min   2.0   无效   cat   步骤   

如果你的jdk是1.7并且在搭建springboot项目时报如上错,请按此步骤,已测试并通过

解决方法步骤:

1.将java版本改为1.7

技术分享图片

 

2.将springboot的版本改为1.4.7,默认的是2.0.1,这里为啥要改成1.4.7因为2.0.1内置的JDK是1.8

技术分享图片

3.点击file-settings-java compiler选择1.7

技术分享图片

4.file-project structure选择Project的JDK版本,Modules的JDK版本,以及SDK版本

技术分享图片

技术分享图片

 

技术分享图片

 

5.再重新运行DemoApplication就OK了

idea 2017.3创建springboot项目报无效的源发行版: 1.8或者Unsupported major.minor version 52.0的解决方案

标签:com   图片   1.7   info   min   2.0   无效   cat   步骤   

原文地址:https://www.cnblogs.com/jbml-154312/p/8983256.html

(1)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有 京ICP备13008772号-2
迷上了代码!