码迷,mamicode.com
首页 > 其他好文 > 详细

P2866 [USACO06NOV]糟糕的一天Bad Hair Day

时间:2018-05-20 10:49:34      阅读:233      评论:0      收藏:0      [点我收藏+]

标签:cio   about   enter   高度   des   一个   ast   ali   描述   

P2866 [USACO06NOV]糟糕的一天Bad Hair Day

题目描述

Some of Farmer John‘s N cows (1 ≤ N ≤ 80,000) are having a bad hair day! Since each cow is self-conscious about her messy hairstyle, FJ wants to count the number of other cows that can see the top of other cows‘ heads.

Each cow i has a specified height hi (1 ≤ hi ≤ 1,000,000,000) and is standing in a line of cows all facing east (to the right in our diagrams). Therefore, cow i can see the tops of the heads of cows in front of her (namely cows i+1, i+2, and so on), for as long as these cows are strictly shorter than cow i.

Consider this example:

        =

=       =

=   -   =         Cows facing right -->

=   =   =

= - = = =

= = = = = =

1 2 3 4 5 6 Cow#1 can see the hairstyle of cows #2, 3, 4

Cow#2 can see no cow‘s hairstyle

Cow#3 can see the hairstyle of cow #4

Cow#4 can see no cow‘s hairstyle

Cow#5 can see the hairstyle of cow 6

Cow#6 can see no cows at all!

Let ci denote the number of cows whose hairstyle is visible from cow i; please compute the sum of c1 through cN.For this example, the desired is answer 3 + 0 + 1 + 0 + 1 + 0 = 5.

农民约翰的某N(1 < N < 80000)头奶牛正在过乱头发节!由于每头牛都意识到自己凌乱不堪 的发型,约翰希望统计出能够看到其他牛的头发的牛的数量.

每一头牛i有一个高度所有N头牛面向东方排成一排,牛N在最前面,而 牛1在最后面.第i头牛可以看到她前面的那些牛的头,只要那些牛的高度严格小于她的高度,而且 中间没有比hi高或相等的奶牛阻隔.

让N表示第i头牛可以看到发型的牛的数量;请输出Ci的总和

输入输出格式

输入格式:

 

Line 1: The number of cows, N.

Lines 2..N+1: Line i+1 contains a single integer that is the height of cow i.

 

输出格式:

 

Line 1: A single integer that is the sum of c1 through cN.

 

输入输出样例

输入样例#1:
6
10
3
7
4
12
2

  

输出样例#1:
5  

  


 

模拟题。可以搞一下

………………万脸懵逼。。。。

woc,我要举报翻译,翻译的和屎一样啊!!!

------------------假装分割线------------------

想想咋做呢。

可以用一个栈保持一个单调的序列。

然后每次把栈的长度加到Ans中。保证这个序列单调即保证我们前面的牛都是可以看到后面的牛的。

---------------这个才是真的分割线--------------

 

#include <stack>
#include <cstdio>
#include <cstring>
#include <iostream>
#include <algorithm>
#define MAXN 80007

using namespace std;

int n, h[MAXN], c[MAXN];
long long Ans;

stack<int> S;

int main() {
	scanf("%d", &n);
	for(int i=1; i<=n; i++) {
		scanf("%d", &h[i]);
		while(!S.empty() && S.top()<=h[i]) {
			S.pop();
		}
		Ans += S.size();
		S.push(h[i]);
	}
	printf("%lld", Ans);
}

 

  

 

 

P2866 [USACO06NOV]糟糕的一天Bad Hair Day

标签:cio   about   enter   高度   des   一个   ast   ali   描述   

原文地址:https://www.cnblogs.com/bljfy/p/9062445.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!