码迷,mamicode.com
首页 > 编程语言 > 详细

nyoj 41-三个数从小到大排序(STL --> sort(a, a+n) 升序)

时间:2018-05-23 00:01:22      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:ora   限制   分析   gre   stream   代码   时间   title   space   

41-三个数从小到大排序


内存限制:64MB 时间限制:3000ms Special Judge: No
accepted:31 submit:44

题目描述:

现在要写一个程序,实现给三个数排序的功能

输入描述:

输入三个正整数

输出描述:

给输入的三个正整数排序

样例输入:

20 7 33

样例输出:

7 20 33

分析:  
  直接使用STL库中的sort函数进行排序

C/C++代码实现(AC):
  
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <cmath>
#include <stack>
#include <map>
#include <queue>
#include <set>

using namespace std;

int main()
{

    int t[3];
    scanf("%d%d%d", &t[0], &t[1], &t[2]);
    sort(t, t+3);
    for(int i = 0; i < 2; ++ i)
        printf("%d ", t[i]);
    printf("%d\n", t[2]);
    return 0;
}

 


nyoj 41-三个数从小到大排序(STL --> sort(a, a+n) 升序)

标签:ora   限制   分析   gre   stream   代码   时间   title   space   

原文地址:https://www.cnblogs.com/GetcharZp/p/9074386.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!