码迷,mamicode.com
首页 > 其他好文 > 详细

畅通工程

时间:2018-06-08 19:24:06      阅读:206      评论:0      收藏:0      [点我收藏+]

标签:cas   政府   TE   near   algo   调查   输出   hid   str   

省政府“畅通工程”的目标是使全省任何两个村庄间都可以实现公路交通(但不一定有直接的公路相连,只要能间接通过公路可达即可)。经过调查评估,得到的统计表中列出了有可能建设公路的若干条道路的成本。现请你编写程序,计算出全省畅通需要的最低成本。 
 

Input

测试输入包含若干测试用例。每个测试用例的第1行给出评估的道路条数 N、村庄数目M ( < 100 );随后的 N 
行对应村庄间道路的成本,每行给出一对正整数,分别是两个村庄的编号,以及此两村庄间道路的成本(也是正整数)。为简单起见,村庄从1到M编号。当N为0时,全部输入结束,相应的结果不要输出。 
 

Output

对每个测试用例,在1行里输出全省畅通需要的最低成本。若统计数据不足以保证畅通,则输出“?”。 
 

Sample Input

3 3
1 2 1
1 3 2
2 3 4
1 3
2 3 2
0 100
 

Sample Output

3 ?
 
直接用prim算法
#include <cstdio>
#include <algorithm>
#include <iostream>
#include <cstring>
#define Maxn 200
#define INF 0x3f3f3f3f
int n,m;
int lowcast[Maxn];
int nearvex[Maxn];
int edge[Maxn][Maxn];
using namespace std;

void prim(int u0)
{
    int i,j;
    int sumweight=0;
    for(i=1;i<=n;i++)
    {
        lowcast[i]=edge[u0][i];
        nearvex[i]=u0;
    }
    nearvex[u0]=-1;
    for(i=1;i<n;i++)
    {
        int mins=INF;
        int v=-1;
        for(j=1;j<=n;j++)
        {
            if(nearvex[j]!=-1 && mins>lowcast[j])
            {
                mins=lowcast[j];
                v=j;
            }
        }
        if(v!=-1)
        {
            nearvex[v]=-1;
            sumweight+=mins;
            for(j=1;j<=n;j++)
            {
                if(nearvex[j]!=-1 && lowcast[j] > edge[v][j])
                {
                    lowcast[j] = edge[v][j];
                    nearvex[j]=v;
                }
            }
        }
        else{
            printf("?\n");
            return ;
        }
    }
    printf("%d\n",sumweight);
    return ;
}
int main()
{
    while(scanf("%d%d",&m,&n)!=EOF && m!=0)
    {
        int i,j,a,b,c;
        memset(edge,0,sizeof(edge));
        for(i=0;i<m;i++){
            scanf("%d%d%d",&a,&b,&c);
            edge[a][b]=edge[b][a]=c;
        }
        for(i=1;i<=n;i++){
            for(j=1;j<=n;j++){
                if(i==j)
                    edge[i][j]=0;
                else if(edge[i][j]==0)
                    edge[i][j]=INF;
            }
        }
        prim(1);
    }
    return 0;
}

 

畅通工程

标签:cas   政府   TE   near   algo   调查   输出   hid   str   

原文地址:https://www.cnblogs.com/coder-tcm/p/9157137.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!