码迷,mamicode.com
首页 > 其他好文 > 详细

1094 The Largest Generation (25)

时间:2018-06-09 20:31:19      阅读:132      评论:0      收藏:0      [点我收藏+]

标签:mil   case   level   children   with   ace   test   问题   数组   

A family hierarchy is usually presented by a pedigree tree where all the nodes on the same level belong to the same generation. Your task is to find the generation with the largest population.

Input Specification:

Each input file contains one test case. Each case starts with two positive integers N (&lt100) which is the total number of family members in the tree (and hence assume that all the members are numbered from 01 to N), and M (&ltN) which is the number of family members who have children. Then M lines follow, each contains the information of a family member in the following format:

ID K ID[1] ID[2] ... ID[K]

where ID is a two-digit number representing a family member, K (&gt0) is the number of his/her children, followed by a sequence of two-digit ID‘s of his/her children. For the sake of simplicity, let us fix the root ID to be 01. All the numbers in a line are separated by a space.

Output Specification:

For each test case, print in one line the largest population number and the level of the corresponding generation. It is assumed that such a generation is unique, and the root level is defined to be 1.

Sample Input:

23 13
21 1 23
01 4 03 02 04 05
03 3 06 07 08
06 2 12 13
13 1 21
08 2 15 16
02 2 09 10
11 2 19 20
17 1 22
05 1 11
07 1 14
09 1 17
10 1 18

Sample Output:

9 4

题目大意:给出一棵树,找出节点最多的层
pat的这类题都有套路,摸清楚套路就比较简单了,两个步骤解决这个问题,1.二维数组建立树, 2,dfs遍历树。
#include<iostream>
#include<vector>
using namespace std;
vector<vector<int>> v(102);
vector<int> num(102, 0);
int maxdepth=0;
void dfs(int root, int depth){
  num[depth]++;
  if(num[depth]>num[maxdepth]) maxdepth=depth;
  for(int i=0; i<v[root].size(); i++) dfs(v[root][i], depth+1);
}
int main(){
  int n, m, i;
  cin>>n>>m;
  for(i=0; i<m; i++){
    int root, k, leaf;
    scanf("%d %d", &root, &k);
    for(int j=0; j<k; j++){
      scanf("%d", &leaf);
      v[root].push_back(leaf);
    }
  }
  dfs(1, 1);
  cout<<num[maxdepth]<<" "<<maxdepth<<endl;
  return 0;
}

 


 

 

 

 

 

 

 

 

1094 The Largest Generation (25)

标签:mil   case   level   children   with   ace   test   问题   数组   

原文地址:https://www.cnblogs.com/mr-stn/p/9160599.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!