码迷,mamicode.com
首页 > 其他好文 > 详细

ACboy needs your help(分组背包)

时间:2018-06-15 21:48:30      阅读:124      评论:0      收藏:0      [点我收藏+]

标签:memset   mem   and   inpu   TE   枚举   lin   string   multiple   

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit? 

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. 
Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. 
N = 0 and M = 0 ends the input. 
Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain. 
Sample Input

2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

3
4
6
题目大意:
先输入n,m代表n个课程和有m天,在输入n*m的矩阵,分别代表经历j天在i课程上,得到的一个权值,求大的权值。
#include <iostream>
#include <cstring>
using namespace std;
int a[105][105],dp[105];
int n,m;
int main()
{
    while(cin>>n>>m,n||m)
    {
        memset(dp,0,sizeof dp);
        for(int i=1;i<=n;i++)
            for(int j=1;j<=m;j++)
                cin>>a[i][j];
        for(int i=1;i<=n;i++)
            for(int j=m;j>=1;j--)
                for(int k=1;k<=j;k++)///枚举在i课程的天数
                    dp[j]=max(dp[j],dp[j-k]+a[i][k]);
        cout<<dp[m]<<\n;
    }
    return 0;
}

 

 

ACboy needs your help(分组背包)

标签:memset   mem   and   inpu   TE   枚举   lin   string   multiple   

原文地址:https://www.cnblogs.com/zdragon1104/p/9188990.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!