码迷,mamicode.com
首页 > 其他好文 > 详细

Cheapest Palindrome(区间DP)

时间:2018-06-15 22:43:19      阅读:213      评论:0      收藏:0      [点我收藏+]

标签:hose   diff   soc   reg   文字   begin   lse   led   ini   

描述

Keeping track of all the cows can be a tricky task so Farmer John has installed a system to automate it. He has installed on each cow an electronic ID tag that the system will read as the cows pass by a scanner. Each ID tag‘s contents are currently a single string with length M (1 ≤ M ≤ 2,000) characters drawn from an alphabet of N (1 ≤ N ≤ 26) different symbols (namely, the lower-case roman alphabet).

Cows, being the mischievous creatures they are, sometimes try to spoof the system by walking backwards. While a cow whose ID is "abcba" would read the same no matter which direction the she walks, a cow with the ID "abcb" can potentially register as two different IDs ("abcb" and "bcba").

FJ would like to change the cows‘s ID tags so they read the same no matter which direction the cow walks by. For example, "abcb" can be changed by adding "a" at the end to form "abcba" so that the ID is palindromic (reads the same forwards and backwards). Some other ways to change the ID to be palindromic are include adding the three letters "bcb" to the begining to yield the ID "bcbabcb" or removing the letter "a" to yield the ID "bcb". One can add or remove characters at any location in the string yielding a string longer or shorter than the original string.

Unfortunately as the ID tags are electronic, each character insertion or deletion has a cost (0 ≤ cost ≤ 10,000) which varies depending on exactly which character value to be added or deleted. Given the content of a cow‘s ID tag and the cost of inserting or deleting each of the alphabet‘s characters, find the minimum cost to change the ID tag so it satisfies FJ‘s requirements. An empty ID tag is considered to satisfy the requirements of reading the same forward and backward. Only letters with associated costs can be added to a string.

输入

Line 1: Two space-separated integers: N and M 
Line 2: This line contains exactly M characters which constitute the initial ID string 
Lines 3..N+2: Each line contains three space-separated entities: a character of the input alphabet and two integers which are respectively the cost of adding and deleting that character.

输出

Line 1: A single line with a single integer that is the minimum cost to change the given name tag.

样例输入

3 4
abcb
a 1000 1100
b 350 700
c 200 800

样例输出

 900

提示

If we insert an "a" on the end to get "abcba", the cost would be 1000. If we delete the "a" on the beginning to get "bcb", the cost would be 1100. If we insert "bcb" at the begining of the string, the cost would be 350 + 200 + 350 = 900, which is the minimum.
题目大意:
给定一个字符串,以及一些字母的删除和添加操作的花费,求将字符串变成回文字符串的最小花费。
#include <bits/stdc++.h>
using namespace std;
const int INF=0x3f3f3f3f;
int dp[2005][2005];
int has[26];
int main()
{
    ios::sync_with_stdio(false);
    string s,ss;
    int n,m;
    cin>>n>>m>>s;
    for(int i=0,x,y;i<n;i++)
        cin>>ss>>x>>y,has[ss[0]-a]=min(x,y);///删除与添加没区别的
    for(int l=1;l<m;l++)
        for(int i=0;i+l<m;i++)
        {
            int j=i+l;
            dp[i][j]=INF;
            if(s[i]==s[j])
                dp[i][j]=dp[i+1][j-1];
            else
            {
                dp[i][j]=min(dp[i][j],dp[i+1][j]+has[s[i]-a]);
                dp[i][j]=min(dp[i][j],dp[i][j-1]+has[s[j]-a]);
            }
        }
    cout<<dp[0][m-1]<<\n;
    return 0;
}

 

Cheapest Palindrome(区间DP)

标签:hose   diff   soc   reg   文字   begin   lse   led   ini   

原文地址:https://www.cnblogs.com/zdragon1104/p/9189134.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!