码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1014 Uniform Generator(题解)

时间:2018-06-20 00:07:17      阅读:147      评论:0      收藏:0      [点我收藏+]

标签:rand   because   code   text   TE   computer   value   ext   turn   

Uniform Generator

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 32990    Accepted Submission(s): 13081


Problem Description
Computer simulations often require random numbers. One way to generate pseudo-random numbers is via a function of the form

seed(x+1) = [seed(x) + STEP] % MOD

where ‘%‘ is the modulus operator.

Such a function will generate pseudo-random numbers (seed) between 0 and MOD-1. One problem with functions of this form is that they will always generate the same pattern over and over. In order to minimize this effect, selecting the STEP and MOD values carefully can result in a uniform distribution of all values between (and including) 0 and MOD-1.

For example, if STEP = 3 and MOD = 5, the function will generate the series of pseudo-random numbers 0, 3, 1, 4, 2 in a repeating cycle. In this example, all of the numbers between and including 0 and MOD-1 will be generated every MOD iterations of the function. Note that by the nature of the function to generate the same seed(x+1) every time seed(x) occurs means that if a function will generate all the numbers between 0 and MOD-1, it will generate pseudo-random numbers uniformly with every MOD iterations.

If STEP = 15 and MOD = 20, the function generates the series 0, 15, 10, 5 (or any other repeating series if the initial seed is other than 0). This is a poor selection of STEP and MOD because no initial seed will generate all of the numbers from 0 and MOD-1.

Your program will determine if choices of STEP and MOD will generate a uniform distribution of pseudo-random numbers.
 

 

Input
Each line of input will contain a pair of integers for STEP and MOD in that order (1 <= STEP, MOD <= 100000).
 

 

Output
For each line of input, your program should print the STEP value right- justified in columns 1 through 10, the MOD value right-justified in columns 11 through 20 and either "Good Choice" or "Bad Choice" left-justified starting in column 25. The "Good Choice" message should be printed when the selection of STEP and MOD will generate all the numbers between and including 0 and MOD-1 when MOD numbers are generated. Otherwise, your program should print the message "Bad Choice". After each output test set, your program should print exactly one blank line.
 

 

Sample Input
3 5 15 20 63923 99999
 

 

Sample Output
3 5 Good Choice 15 20 Bad Choice 63923 99999 Good Choice
 
英语渣, 开始没看明白(囧), 后来师兄说只要两数互质就行:
 
#include<iostream>
#include<cstdio>

using namespace std;

int gcd(int a, int b)
{
    return b == 0? a: gcd(b, a % b);
}
int main()
{
    int a, b;
    while ( cin >> a >> b)
    {
        printf("%10d%10d    ", a, b);
        printf(gcd(a, b) == 1? "Good Choice": "Bad Choice");
        printf("\n\n");
    }
}

所以最后也没看明白题目说什么T^T

 

 
 

HDU 1014 Uniform Generator(题解)

标签:rand   because   code   text   TE   computer   value   ext   turn   

原文地址:https://www.cnblogs.com/mrh-acmer/p/9201680.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!