码迷,mamicode.com
首页 > 其他好文 > 详细

E - Super Jumping! Jumping! Jumping! <HDU 1087>

时间:2018-07-07 22:23:33      阅读:168      评论:0      收藏:0      [点我收藏+]

标签:using   pop   size   backward   absolute   any   case   can   递增   

E - Super Jumping! Jumping! Jumping!

Nowadays, a kind of chess game called “Super Jumping! Jumping! Jumping!” is very popular in HDU. Maybe you are a good boy, and know little about this game, so I introduce it to you now.

技术分享图片


The game can be played by two or more than two players. It consists of a chessboard(棋盘)and some chessmen(棋子), and all chessmen are marked by a positive integer or “start” or “end”. The player starts from start-point and must jumps into end-point finally. In the course of jumping, the player will visit the chessmen in the path, but everyone must jumps from one chessman to another absolutely bigger (you can assume start-point is a minimum and end-point is a maximum.). And all players cannot go backwards. One jumping can go from a chessman to next, also can go across many chessmen, and even you can straightly get to end-point from start-point. Of course you get zero point in this situation. A player is a winner if and only if he can get a bigger score according to his jumping solution. Note that your score comes from the sum of value on the chessmen in you jumping path.
Your task is to output the maximum value according to the given chessmen list.

InputInput contains multiple test cases. Each test case is described in a line as follow:
N value_1 value_2 …value_N
It is guarantied that N is not more than 1000 and all value_i are in the range of 32-int.
A test case starting with 0 terminates the input and this test case is not to be processed.
OutputFor each case, print the maximum according to rules, and one line one case.
Sample Input

3 1 3 2
4 1 2 3 4
4 3 3 2 1
0

Sample Output

4
10
3
题意:求最大递增字串和
#include <iostream>
using namespace std;
int dp[10001],v[10001];
int main()
{
    int n;
    while(cin>>n,n)
    {
        for(int i=0;i<n;i++)
        {
            cin>>v[i];
            dp[i]=0;
        }
        dp[0]=v[0];
        int sum=0;
        for(int i=1;i<n;i++)
        {
            for(int j=0;j<i;j++)
            {
                if(v[j]<v[i])
                {
                    dp[i]=max(dp[i],dp[j]+v[i]);
                }
            }
            dp[i]=max(dp[i],v[i]);
        }
        for(int i=0;i<n;i++)
            sum=max(sum,dp[i]);
        cout<<sum<<endl;
    }
    return 0;
}

 

E - Super Jumping! Jumping! Jumping! <HDU 1087>

标签:using   pop   size   backward   absolute   any   case   can   递增   

原文地址:https://www.cnblogs.com/xuxua/p/9278353.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!