码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1022 Train Problem I(栈的操作规则)

时间:2018-07-15 15:01:19      阅读:159      评论:0      收藏:0      [点我收藏+]

标签:图片   bsp   分析   leaves   mes   inpu   back   its   style   

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1022

Train Problem I

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 45375    Accepted Submission(s): 16966


Problem Description
As the new term comes, the Ignatius Train Station is very busy nowadays. A lot of student want to get back to school by train(because the trains in the Ignatius Train Station is the fastest all over the world ^v^). But here comes a problem, there is only one railway where all the trains stop. So all the trains come in from one side and get out from the other side. For this problem, if train A gets into the railway first, and then train B gets into the railway before train A leaves, train A can‘t leave until train B leaves. The pictures below figure out the problem. Now the problem for you is, there are at most 9 trains in the station, all the trains has an ID(numbered from 1 to n), the trains get into the railway in an order O1, your task is to determine whether the trains can get out in an order O2.
技术分享图片技术分享图片技术分享图片
 

 

Input
The input contains several test cases. Each test case consists of an integer, the number of trains, and two strings, the order of the trains come in:O1, and the order of the trains leave:O2. The input is terminated by the end of file. More details in the Sample Input.
 

 

Output
The output contains a string "No." if you can‘t exchange O2 to O1, or you should output a line contains "Yes.", and then output your way in exchanging the order(you should output "in" for a train getting into the railway, and "out" for a train getting out of the railway). Print a line contains "FINISH" after each test case. More details in the Sample Output.
 

 

Sample Input
3 123 321 3 123 312
 

 

Sample Output
Yes. in in in out out out FINISH No. FINISH
Hint
Hint
For the first Sample Input, we let train 1 get in, then train 2 and train 3. So now train 3 is at the top of the railway, so train 3 can leave first, then train 2 and train 1. In the second Sample input, we should let train 3 leave first, so we have to let train 1 get in, then train 2 and train 3. Now we can let train 3 leave. But after that we can‘t let train 1 leave before train 2, because train 2 is at the top of the railway at the moment. So we output "No.".
 

 

Author
Ignatius.L
 

 

Recommend
We have carefully selected several similar problems for you:  1026 1023 1020 1032 1001 
 
分析:
此题不真正的仔细读难理解出事栈的应用,容易想成反序相等就yes的问题,此题题意是说输入的两列字符串,第一列表示进入的顺序,第二列表示出去的顺序,问你是否符合后进先出。
举出一列数据 7 1234567 4321576
上面数据应该是 in in in in out out out out in out in in out out;
所以不是反序才行 可以进到一半就出的
 
stl就是好用啊!
 
code:
#include<bits/stdc++.h>
using namespace std;
typedef long long LL;
int main()
{
    int n,i,j;
    string str1,str2;
    while(cin>>n>>str1>>str2)
    {
        stack<char> s;
        vector<string> v;
        for( i=0,j=0;i<n&&j<n;i++)
        {
            s.push(str1[i]);//元素进栈
            v.push_back("in");//字符压进容器
            while(s.top()==str2[j])//匹配
            {
                if(!s.empty())
                {
                    s.pop();
                    v.push_back("out");
                }
                j++;
                if(s.empty())
                    break;
            }
        }
        if(j==n)//判断依据
        {
            printf("Yes.\n");
            for(i=0;i<v.size();i++)
                cout<<v[i]<<endl;
            cout<<"FINISH"<<endl;
        }else
        {
            cout<<"No."<<endl<<"FINISH"<<endl;
        }
    }
    return 0;
}

 

 

HDU 1022 Train Problem I(栈的操作规则)

标签:图片   bsp   分析   leaves   mes   inpu   back   its   style   

原文地址:https://www.cnblogs.com/yinbiao/p/9313425.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!