码迷,mamicode.com
首页 > 其他好文 > 详细

HDU 1159 Common Subsequence(裸LCS)

时间:2018-07-21 22:37:32      阅读:176      评论:0      收藏:0      [点我收藏+]

标签:tin   put   arch   esc   mission   nts   bsp   print   char   

传送门:

http://acm.hdu.edu.cn/showproblem.php?pid=1159

Common Subsequence

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 47676    Accepted Submission(s): 21890


Problem Description
A subsequence of a given sequence is the given sequence with some elements (possible none) left out. Given a sequence X = <x1, x2, ..., xm> another sequence Z = <z1, z2, ..., zk> is a subsequence of X if there exists a strictly increasing sequence <i1, i2, ..., ik> of indices of X such that for all j = 1,2,...,k, xij = zj. For example, Z = <a, b, f, c> is a subsequence of X = <a, b, c, f, b, c> with index sequence <1, 2, 4, 6>. Given two sequences X and Y the problem is to find the length of the maximum-length common subsequence of X and Y.
The program input is from a text file. Each data set in the file contains two strings representing the given sequences. The sequences are separated by any number of white spaces. The input data are correct. For each set of data the program prints on the standard output the length of the maximum-length common subsequence from the beginning of a separate line.
 

 

Sample Input
abcfbc abfcab programming contest abcd mnp
 

 

Sample Output
4 2 0
 

 

Source
 
分析:
裸的LCS(最长公共子序列问题)
code:
#include<stdio.h>
#include<string.h>
#include<memory>
using namespace std;
#define max_v 1005
char x[max_v],y[max_v];
int dp[max_v][max_v];
int l1,l2;
int main()
{
    while(~scanf("%s %s",x,y))
    {
        l1=strlen(x);
        l2=strlen(y);
        memset(dp,0,sizeof(dp));
        for(int i=1;i<=l1;i++)
        {
            for(int j=1;j<=l2;j++)
            {
                if(x[i-1]==y[j-1])
                {
                    dp[i][j]=dp[i-1][j-1]+1;
                }else
                {
                    dp[i][j]=max(dp[i-1][j],dp[i][j-1]);
                }
            }
        }
        printf("%d\n",dp[l1][l2]);
    }
    return 0;
}

 

HDU 1159 Common Subsequence(裸LCS)

标签:tin   put   arch   esc   mission   nts   bsp   print   char   

原文地址:https://www.cnblogs.com/yinbiao/p/9347975.html

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!