码迷,mamicode.com
首页 > 其他好文 > 详细

HDU-2844-Coins(多重背包)

时间:2014-10-03 02:05:13      阅读:356      评论:0      收藏:0      [点我收藏+]

标签:des   style   http   color   io   os   ar   for   sp   

Problem Description
Whuacmers use coins.They have coins of value A1,A2,A3...An Silverland dollar. One day Hibix opened purse and found there were some coins. He decided to buy a very nice watch in a nearby shop. He wanted to pay the exact price(without change) and he known the price would not more than m.But he didn‘t know the exact price of the watch.

You are to write a program which reads n,m,A1,A2,A3...An and C1,C2,C3...Cn corresponding to the number of Tony‘s coins of value A1,A2,A3...An then calculate how many prices(form 1 to m) Tony can pay use these coins.
 

Input
The input contains several test cases. The first line of each test case contains two integers n(1 ≤ n ≤ 100),m(m ≤ 100000).The second line contains 2n integers, denoting A1,A2,A3...An,C1,C2,C3...Cn (1 ≤ Ai ≤ 100000,1 ≤ Ci ≤ 1000). The last test case is followed by two zeros.
 

Output
For each test case output the answer on a single line.
 

Sample Input
3 10 1 2 4 2 1 1 2 5 1 4 2 1 0 0
 

Sample Output
8 4
 

Source
 

思路:经典背包问题。

#include <cstdio>
#include <algorithm>
using namespace std;

int d[105],c[105],dp[100005];

int main()
{
    int n,m,i,j,k,ans;

    while(~scanf("%d%d",&n,&m) && n+m)
    {
        for(i=0;i<n;i++) scanf("%d",&d[i]);
        for(i=0;i<n;i++) scanf("%d",&c[i]);

        for(i=0;i<=m;i++) dp[i]=0;

        for(i=0;i<n;i++)
        {
            if(d[i]*c[i]>=m)
            {
                for(j=d[i];j<=m;j++) dp[j]=max(dp[j],dp[j-d[i]]+d[i]);
            }
            else
            {
                k=1;

                while(((k<<1)-1)<=c[i])
                {
                    for(j=m;j>=k*d[i];j--) dp[j]=max(dp[j],dp[j-k*d[i]]+k*d[i]);

                    k<<=1;
                }

                if(k-1<c[i])
                {
                    k=(c[i]-k+1)*d[i];

                    for(j=m;j>=k;j--) dp[j]=max(dp[j],dp[j-k]+k);
                }
            }
        }

        ans=0;

        for(i=1;i<=m;i++) if(dp[i]==i) ans++;

        printf("%d\n",ans);
    }
}

HDU-2844-Coins(多重背包)

标签:des   style   http   color   io   os   ar   for   sp   

原文地址:http://blog.csdn.net/faithdmc/article/details/39744159

(0)
(0)
   
举报
评论 一句话评论(0
登录后才能评论!
© 2014 mamicode.com 版权所有  联系我们:gaon5@hotmail.com
迷上了代码!